summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn A. Leuenhagen2024-02-02 02:16:20 -0500
committerJohn A. Leuenhagen2024-02-02 02:18:14 -0500
commit7c2efc2debd858a527c6928b273f1bc2765b652d (patch)
tree803790fc1feb22b059c180ab95ba4f936131c666
parente409317b46f4d1c3514a51659f90c13ccf96d218 (diff)
downloadaur-7c2efc2debd858a527c6928b273f1bc2765b652d.tar.gz
Undo e999aac; keep CARCH in executable filenames.
This is important for makepkg -g, as otherwise it will think that the x86_64 executable is also the armv7h and aarch64 executables. This results in the produced checksum being incorrect for all architectures but the first downloaded. The only difference in this commit compared to how things used to be before e999aac is that the CARCH variable is no longer used on the source lines, as that will cause all executable names to use only one architecture: the one that is targeted when running makepkg. If you look at the .SRCINFO before e999aac, you can see that x86_64 is in all filenames, even the armv7h and aarch64 ones. The CARCH variable is still used when running `install`, however, as in that case you actually want the executable for whichever architecture is being targeted.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d1b90bb435b0..ef0f6e0cddb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,11 +13,11 @@ pkgbase = wormhole-william-bin
source = wormhole-william-1.0.6-LICENSE::https://github.com/psanford/wormhole-william/raw/v1.0.6/LICENSE
sha256sums = 038dd1af9f5ff03d5c0d8d4f0afc975d18d4559f46abe95c56e17023ad912157
sha256sums = ee47201dec4798fed875d8768ebfd04f186a74f1bbffe315a0c96b423331f462
- source_x86_64 = wormhole-william-1.0.6::https://github.com/psanford/wormhole-william/releases/download/v1.0.6/wormhole-william-linux-amd64
+ source_x86_64 = wormhole-william-1.0.6-x86_64::https://github.com/psanford/wormhole-william/releases/download/v1.0.6/wormhole-william-linux-amd64
sha256sums_x86_64 = 68bd9d4e94a01f237bd65d79c81db054269cc4acf034b8ea52bcd220f08d0d47
- source_armv7h = wormhole-william-1.0.6::https://github.com/psanford/wormhole-william/releases/download/v1.0.6/wormhole-william-linux-arm7
+ source_armv7h = wormhole-william-1.0.6-armv7h::https://github.com/psanford/wormhole-william/releases/download/v1.0.6/wormhole-william-linux-arm7
sha256sums_armv7h = de9d68d47f9743f6d9653aad5fdbcc329e85c5aa470172603285bbee00f5e2d9
- source_aarch64 = wormhole-william-1.0.6::https://github.com/psanford/wormhole-william/releases/download/v1.0.6/wormhole-william-linux-arm64
+ source_aarch64 = wormhole-william-1.0.6-aarch64::https://github.com/psanford/wormhole-william/releases/download/v1.0.6/wormhole-william-linux-arm64
sha256sums_aarch64 = f725f669f6a0261fe542af037f0b4346b2c6bfb99b527dac4ca5f100c67a1ca1
pkgname = wormhole-william-bin
diff --git a/PKGBUILD b/PKGBUILD
index 31e089f683ff..5d2b8c42c576 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,9 +15,9 @@ conflicts=("${_pkgname}")
source=("${_pkgname}-${pkgver}-README.md::${url}/raw/v${pkgver}/README.md"
"${_pkgname}-${pkgver}-LICENSE::${url}/raw/v${pkgver}/LICENSE")
-source_x86_64=("${_pkgname}-${pkgver}::${url}/releases/download/v${pkgver}/${_pkgname}-linux-amd64")
-source_armv7h=("${_pkgname}-${pkgver}::${url}/releases/download/v${pkgver}/${_pkgname}-linux-arm7")
-source_aarch64=("${_pkgname}-${pkgver}::${url}/releases/download/v${pkgver}/${_pkgname}-linux-arm64")
+source_x86_64=("${_pkgname}-${pkgver}-x86_64::${url}/releases/download/v${pkgver}/${_pkgname}-linux-amd64")
+source_armv7h=("${_pkgname}-${pkgver}-armv7h::${url}/releases/download/v${pkgver}/${_pkgname}-linux-arm7")
+source_aarch64=("${_pkgname}-${pkgver}-aarch64::${url}/releases/download/v${pkgver}/${_pkgname}-linux-arm64")
sha256sums=('038dd1af9f5ff03d5c0d8d4f0afc975d18d4559f46abe95c56e17023ad912157'
'ee47201dec4798fed875d8768ebfd04f186a74f1bbffe315a0c96b423331f462')
@@ -26,7 +26,7 @@ sha256sums_armv7h=('de9d68d47f9743f6d9653aad5fdbcc329e85c5aa470172603285bbee00f5
sha256sums_aarch64=('f725f669f6a0261fe542af037f0b4346b2c6bfb99b527dac4ca5f100c67a1ca1')
package() {
- install -Dm755 "${_pkgname}-${pkgver}" "${pkgdir}/usr/bin/${_pkgname}"
+ install -Dm755 "${_pkgname}-${pkgver}-${CARCH}" "${pkgdir}/usr/bin/${_pkgname}"
install -Dm644 "${_pkgname}-${pkgver}-README.md" "${pkgdir}/usr/share/doc/${_pkgname}/README.md"
install -Dm644 "${_pkgname}-${pkgver}-LICENSE" "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
}