summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Sloniker2021-09-13 15:03:56 -0700
committerSamuel Sloniker2021-09-13 15:03:56 -0700
commitaa9871436caf971b5577822390339d6eca406447 (patch)
tree921e07d5a6bcbe2079a748695e381e7886b415be
downloadaur-wormpy.tar.gz
v1.0
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD40
3 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a44437bda070
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = wormpy
+ pkgdesc = bsdgames worm, ported to Python and improved
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/kj7rrv/wormpy
+ arch = any
+ license = MIT
+ depends = python-blessings
+ depends = python-timeout-decorator
+ source = https://github.com/kj7rrv/wormpy/archive/refs/tags/v1.0.tar.gz
+ sha256sums = 458b983498b4af308b5518860c5411c55f8e7061115e2c1a46097413fc3d2129
+
+pkgname = wormpy
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b03c1f9d8a0c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Samuel Sloniker <sam@kj7rrv.com>
+
+pkgname=wormpy
+pkgver=1.0
+pkgrel=1
+epoch=
+pkgdesc="bsdgames worm, ported to Python and improved"
+arch=('any')
+url="https://github.com/kj7rrv/wormpy"
+license=('MIT')
+groups=()
+depends=('python-blessings' 'python-timeout-decorator')
+makedepends=()
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/kj7rrv/wormpy/archive/refs/tags/v$pkgver.tar.gz")
+noextract=()
+sha256sums=('458b983498b4af308b5518860c5411c55f8e7061115e2c1a46097413fc3d2129')
+validpgpkeys=()
+
+prepare() {
+ :
+}
+
+build() {
+ :
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ mkdir -p $pkgdir/usr
+ bash ./install.sh $pkgdir/usr /usr
+}