summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorkus2019-05-02 17:14:35 +0930
committerTorkus2019-05-02 17:14:35 +0930
commitf00b3bac25ea7e032cbaef87ea3c760dd7d9d0ad (patch)
tree78fb37173dfe62fc82f6495aceb3cd2ea49f0df5
downloadaur-f00b3bac25ea7e032cbaef87ea3c760dd7d9d0ad.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d02152f9df5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wowman
+ pkgdesc = World of Warcraft addon manager. F/OSS, ad-free and privacy respecting.
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/ogri-la/wowman
+ arch = x86_64
+ license = AGPL
+ depends = java-runtime
+ provides = wowman
+ conflicts = wowman
+ noextract = wowman-0.5.0-standalone.jar
+ source = https://github.com/ogri-la/wowman/releases/download/0.5.0/wowman-0.5.0-standalone.jar
+ sha256sums = 2edddf76f3673d0de91858bb1d9b1b64e8dc5c408d190524b8c96ba6e2d98c2f
+
+pkgname = wowman
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..301c0206f9e2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg/
+src/
+*.jar
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..00f1ec8b8ba3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Author: Torkus
+# Maintainer: Torkus <48141663+ogri-la@users.noreply.github.com>
+pkgname=wowman
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="World of Warcraft addon manager. F/OSS, ad-free and privacy respecting."
+arch=("x86_64")
+url="https://github.com/ogri-la/wowman"
+license=("AGPL")
+depends=("java-runtime")
+provides=("$pkgname")
+conflicts=("$pkgname")
+# e.g.: "https://github.com/ogri-la/wowman/releases/download/0.5.0/wowman-0.5.0-standalone.jar"
+source=("https://github.com/ogri-la/wowman/releases/download/$pkgver/$pkgname-$pkgver-standalone.jar")
+noextract=("$pkgname-$pkgver-standalone.jar")
+sha256sums=("2edddf76f3673d0de91858bb1d9b1b64e8dc5c408d190524b8c96ba6e2d98c2f")
+
+# following: https://wiki.archlinux.org/index.php/Java_package_guidelines
+package() {
+ mkdir -p "$pkgdir/usr/share/java/$pkgname"
+ mkdir -p "$pkgdir/usr/bin"
+
+ cp "$pkgname-$pkgver-standalone.jar" "$pkgdir/usr/share/java/$pkgname/"
+
+ # a simple executable wrapper around the jar file
+ outpath="$pkgdir/usr/bin/$pkgname"
+ printf "#!/bin/sh\nexec /usr/bin/java -jar \"/usr/share/java/$pkgname/$pkgname-$pkgver-standalone.jar\" \"\$@\"" > "$outpath"
+ chmod +x "$outpath"
+}