summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwowario2021-09-01 20:37:31 +0300
committerwowario2021-09-01 20:37:31 +0300
commita7cf8d9dca2a1c1945faf5c41196cdfc7a3cd24f (patch)
tree684c4714bfa52d184a8be95faed89b96df2a1850
parent8815c5ad8f593ae419c37cb93c512a23668ba638 (diff)
downloadaur-a7cf8d9dca2a1c1945faf5c41196cdfc7a3cd24f.tar.gz
bump to v0.10.1
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
-rw-r--r--wownero.sysusers1
-rw-r--r--wownero.tmpfiles1
4 files changed, 56 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4e4345ae752..11394be5fb31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wownero-git
- pkgdesc = a fairly launched privacy-centric meme coin with no premine and a finite supply
- pkgver = 0.10.0.3.2bdd70d65d
+ pkgdesc = Wownero: a fairly launched privacy-centric meme coin with no premine and a finite supply
+ pkgver = 0.10.1.0
pkgrel = 1
url = https://wownero.org/
arch = x86_64
@@ -14,13 +14,27 @@ pkgbase = wownero-git
depends = readline
depends = zeromq
depends = pcsclite
+ depends = hidapi
depends = protobuf
- depends = libpgm
- depends = unbound
- depends = libsodium
+ depends = libusb
+ depends = libudev.so
source = wownero::git+https://git.wownero.com/wownero/wownero.git
+ source = git+https://github.com/monero-project/unbound.git
+ source = git+https://github.com/monero-project/supercop.git
+ source = git+https://github.com/monero-project/miniupnp.git
+ source = git+https://github.com/Tencent/rapidjson.git
+ source = git+https://git.wownero.com/wownero/RandomWOW.git
+ source = wownero.sysusers
+ source = wownero.tmpfiles
source = monero-boost1.76.patch::https://github.com/selsta/monero/commit/c28d2f7c.patch
sha512sums = SKIP
sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
pkgname = wownero-git
diff --git a/PKGBUILD b/PKGBUILD
index bb7c5631ec31..1a9d4fc1eec9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,70 @@
# Maintainer: wowario <wowario[at]protonmail[dot]com>
pkgname=wownero-git
-pkgver=0.10.0.3.2bdd70d65d
+pkgver=0.10.1.0
pkgrel=1
-pkgdesc="a fairly launched privacy-centric meme coin with no premine and a finite supply"
+pkgdesc="Wownero: a fairly launched privacy-centric meme coin with no premine and a finite supply"
license=('BSD')
arch=('x86_64')
url="https://wownero.org/"
-depends=('boost-libs' 'openssl' 'readline' 'zeromq' 'pcsclite' 'protobuf' 'libpgm' 'unbound' 'libsodium')
+depends=('boost-libs' 'libunwind' 'openssl' 'readline' 'zeromq' 'pcsclite' 'hidapi' 'protobuf' 'libusb' 'libudev.so')
makedepends=('git' 'cmake' 'boost')
source=(
"${pkgname}"::"git+https://git.wownero.com/wownero/wownero.git"
+ "git+https://github.com/monero-project/unbound.git"
+ "git+https://github.com/monero-project/supercop.git"
+ "git+https://github.com/monero-project/miniupnp.git"
+ "git+https://github.com/Tencent/rapidjson.git"
+ "git+https://git.wownero.com/wownero/RandomWOW.git"
+ "wownero.sysusers"
+ "wownero.tmpfiles"
monero-boost1.76.patch::https://github.com/selsta/monero/commit/c28d2f7c.patch)
sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'SKIP')
+)
prepare() {
cd "${pkgname}"
- git submodule update --init --recursive
+ git submodule init
+ git config submodule.external/unbound.url "$srcdir/unbound"
+ git config submodule.external/supercop.url "$srcdir/supercop"
+ git config submodule.external/miniupnp.url "$srcdir/miniupnp"
+ git config submodule.external/rapidjson.url "$srcdir/rapidjson"
+ git config submodule.external/RandomWOW.url "$srcdir/RandomWOW"
+ git submodule update
+
patch -p1 < ../monero-boost1.76.patch # Fix build with boost 1.76
}
build() {
cd "${pkgname}"
mkdir -p build && cd build
- cmake -D BUILD_TESTS=OFF -D USE_DEVICE_TREZOR=OFF -D CMAKE_BUILD_TYPE=release -D ARCH=default ../
+ cmake -D BUILD_TESTS=OFF -D CMAKE_BUILD_TYPE=release -D ARCH=default ../
make
}
package() {
+ backup=('etc/wownerod.conf')
cd "${pkgname}"
install -Dm644 "LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "wownerod.conf" "${pkgdir}/etc/wownerod.conf"
+ install -Dm644 "utils/systemd/wownerod.service" "${pkgdir}/usr/lib/systemd/system/wownerod.service"
+ install -Dm644 "../wownero.sysusers" "${pkgdir}/usr/lib/sysusers.d/wownero.conf"
+ install -Dm644 "../wownero.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/wownero.conf"
+
install -Dm755 "build/bin/wownero-wallet-cli" \
"build/bin/wownero-wallet-rpc" \
"build/bin/wownerod" \
-t "${pkgdir}/usr/bin"
}
+
+# vim: ts=2 sw=2 et:
diff --git a/wownero.sysusers b/wownero.sysusers
new file mode 100644
index 000000000000..68e56937d1d1
--- /dev/null
+++ b/wownero.sysusers
@@ -0,0 +1 @@
+u wownero - - /var/lib/wownero
diff --git a/wownero.tmpfiles b/wownero.tmpfiles
new file mode 100644
index 000000000000..e3c82369261f
--- /dev/null
+++ b/wownero.tmpfiles
@@ -0,0 +1 @@
+d /var/lib/wownero 0770 wownero wownero - -