summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Fields2018-12-24 01:12:04 -0500
committerMatt Fields2018-12-24 01:33:16 -0500
commitf3d6b63081aa9ba30e72a4751ec76592b4c8f69a (patch)
tree3f914233963cb51c91fe2bc2d6dbc68415e73ee6
parentc6bc203b4c3f26313e524b5f324017f146f0f72d (diff)
downloadaur-f3d6b63081aa9ba30e72a4751ec76592b4c8f69a.tar.gz
Updated to use wp-cli-bundle
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD25
2 files changed, 21 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 15d71a2f2000..ca6d9210d4db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,15 @@
pkgbase = wp-cli-git
pkgdesc = A command-line tool for managing WordPress
- pkgver = r7283.f9f27c5f
- pkgrel = 1
+ pkgver = r8814.ae5557d7
+ pkgrel = 2
url = http://wp-cli.org/
arch = any
license = MIT
makedepends = git
- makedepends = php-composer
+ makedepends = composer
depends = php
conflicts = wp-cli
- source = wp-cli-git::git+https://github.com/wp-cli/wp-cli.git
+ source = wp-cli-git::git+https://github.com/wp-cli/wp-cli-bundle.git
sha256sums = SKIP
pkgname = wp-cli-git
diff --git a/PKGBUILD b/PKGBUILD
index 65f77fd597d4..a9114fda1c39 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,18 @@
-# Maintainer: Peter Hoeg <peter@hoeg.com>
+# Maintainer: Matt Fields (0x6d617474) <aur at 0x6d617474 dot net>
+# Contributor: Peter Hoeg <peter@hoeg.com>
# Contributor: Patrick Burroughs (Celti) <celti@celti.name>
pkgname=wp-cli-git
-pkgver=r7283.f9f27c5f
-pkgrel=1
+pkgver=r8814.ae5557d7
+pkgrel=2
pkgdesc="A command-line tool for managing WordPress"
url="http://wp-cli.org/"
arch=('any')
license=('MIT')
depends=('php')
-makedepends=('git' 'php-composer')
+makedepends=('git' 'composer')
conflicts=('wp-cli')
-source=("$pkgname::git+https://github.com/wp-cli/wp-cli.git")
+source=("$pkgname::git+https://github.com/wp-cli/wp-cli-bundle.git")
sha256sums=('SKIP')
pkgver() {
@@ -29,13 +30,21 @@ prepare() {
build() {
cd ${pkgname}
- composer update --no-interaction --prefer-dist
+ # Replace specific version numbers with dev-master to pull latest versions
+ sed -i 's/"^[0-9]\+"/"dev-master"/g' composer.json
+ sed -i 's/"^[0-9]\+\.[0-9]\+\.[0-9]\+"/"dev-master"/g' composer.json
+ sed -i 's/"[0-9]\+\.[0-9]\+\.x-dev"/"dev-master"/g' composer.json
+ composer update --no-interaction --prefer-dist --no-scripts && composer dump
+ echo -n "Building phar... "
php -dphar.readonly=off utils/make-phar.php wp-cli.phar --quiet
+ echo "Done!"
}
check() {
cd ${pkgname}
- ./vendor/bin/phpunit
+ composer phpunit
+
+ echo -n "Binary reporting as "
php ./wp-cli.phar --version
}
@@ -43,5 +52,5 @@ package() {
cd ${pkgname}
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
install -Dm655 wp-cli.phar "${pkgdir}/usr/bin/wp"
- install -Dm644 utils/wp-completion.bash "${pkgdir}/usr/share/bash-completion/completions/wp"
+ install -Dm644 vendor/wp-cli/wp-cli/utils/wp-completion.bash "${pkgdir}/usr/share/bash-completion/completions/wp"
}