summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2020-03-27 17:17:46 +0100
committerhaawda2020-03-27 17:17:46 +0100
commit8036b45f662491f54fe6182ea3f0cfdb1275f2d5 (patch)
treee2fcff02adf77791555434e0a884766b696cdd37
downloadaur-8036b45f662491f54fe6182ea3f0cfdb1275f2d5.tar.gz
initial upload
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD48
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..59f8aa7740ff
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wp2latex-hg
+ pkgdesc = Converts WordPerfect document formats to LaTeX
+ pkgver = r369.690681b7d114
+ pkgrel = 1
+ url = http://www.penguin.cz/~fojtik/wp2latex/wp2latex.htm
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = mercurial
+ depends = libjpeg
+ depends = gcc-libs
+ depends = libpng
+ options = !strip
+ source = wp2latex::hg+https://bitbucket.org/JaFojtik/wp2latex
+ sha256sums = SKIP
+
+pkgname = wp2latex-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..354d7a0558c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Contributor: Stefan Husmann <stefan-husmann@t-online.de>
+
+pkgname=wp2latex-hg
+pkgver=r369.690681b7d114
+pkgrel=1
+pkgdesc="Converts WordPerfect document formats to LaTeX"
+url="http://www.penguin.cz/~fojtik/${pkgname%-hg}/${pkgname%-hg}.htm"
+arch=('i686' 'x86_64')
+license=('GPL')
+source=("${pkgname%-hg}::hg+https://bitbucket.org/JaFojtik/wp2latex")
+sha256sums=('SKIP')
+depends=('libjpeg' 'gcc-libs' 'libpng')
+makedepends=('mercurial')
+options=('!strip')
+
+pkgver() {
+ cd ${pkgname%-hg}
+ printf "r%s.%s" "$(hg identify -n)" "$(hg identify -i)"
+}
+#prepare() {
+#}
+
+build() {
+ # normal build
+ cd ${pkgname%-hg}/trunk
+ CXXFLAGS+=" -fpermissive" ./configure --prefix=/usr
+ make x2latex
+}
+
+package() {
+ cd ${pkgname%-hg}/trunk
+ install -Dm755 "$srcdir"/${pkgname%-hg}/trunk/bin/linux/${pkgname%-hg} \
+ "$pkgdir/"usr/bin/${pkgname%-hg}
+ for _i in cs de
+ do
+ install -Dm644 \
+ "$srcdir"/${pkgname%-hg}/trunk/doc/locale/${_i}/lc_messages/${pkgname%-hg}.mo \
+ "$pkgdir"/usr/share/locale/${_i}/LC_MESSAGES/${pkgname%-hg}.mo
+ done
+ install -Dm644 "$srcdir"/${pkgname%-hg}/trunk/doc/${pkgname%-hg}.1 \
+ "$pkgdir"/usr/share/man/man1/${pkgname%-hg}.1
+ install -d "$pkgdir"/usr/share/${pkgname%-hg}/doc
+ cp -R "$srcdir"/${pkgname%-hg}/trunk/doc/program.man/* \
+ "$pkgdir"/usr/share/${pkgname%-hg}/doc
+ install -d "$pkgdir"/usr/share/texmf/tex/latex/${pkgname%-hg}
+ cp -r "$srcdir"/${pkgname%-hg}/trunk/styles.tex \
+ "$pkgdir"/usr/share/texmf/tex/latex/${pkgname%-hg}
+}