summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorloh.tar2018-07-12 22:04:08 +0200
committerloh.tar2018-07-12 22:04:08 +0200
commitc8b2ec50c16a057db9bcbb0f154876a51ef7e09d (patch)
tree780602671e691f0c35233edf454c2fdd74b4caba
downloadaur-c8b2ec50c16a057db9bcbb0f154876a51ef7e09d.tar.gz
Hello Arch-World!
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD26
3 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d6ae87245f19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wpa-cute
+ pkgdesc = A graphical wpa_supplicant front end
+ pkgver = 0.7
+ pkgrel = 1
+ url = https://github.com/loh-tar/wpa-cute
+ arch = x86_64
+ license = BSD
+ depends = qt5-base
+ depends = wpa_supplicant
+ source = wpa-cute-0.7.tar.gz::https://github.com/loh-tar/wpa-cute/archive/v0.7.tar.gz
+ md5sums = 570233ecebefd810419bc79326ae7bf9
+
+pkgname = wpa-cute
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6ae0b18a1f6c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3256850474b7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: loh.tar <loh.tar at googlemail dot com>
+pkgname="wpa-cute"
+pkgver="0.7"
+pkgrel="1"
+pkgdesc="A graphical wpa_supplicant front end"
+arch=("x86_64")
+url="https://github.com/loh-tar/$pkgname"
+license=("BSD")
+depends=("qt5-base" "wpa_supplicant")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/loh-tar/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('570233ecebefd810419bc79326ae7bf9')
+
+build() {
+ cd "$pkgname-$pkgver/src"
+ qmake-qt5
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver/src"
+ install -Dm755 "wpa-cute" "${pkgdir}/usr/bin/wpa-cute"
+ install -Dm644 "icons/wpa_gui.svg" "${pkgdir}/usr/share/pixmaps/wpa-cute.svg"
+ install -Dm644 "wpa-cute.desktop" "${pkgdir}/usr/share/applications/wpa-cute.desktop"
+ install -Dm644 "../doc/wpa-cute.8" "${pkgdir}/usr/share/man/man8/wpa-cute.8"
+ install -Dm644 "../COPYING" "${pkgdir}/usr/share/licenses/$pkgname/COPYING"
+}