summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxdavidwu2019-05-18 19:53:00 +0800
committerxdavidwu2019-05-18 19:53:00 +0800
commit5c9fd6e36785fabcdfb2445912941279044a1949 (patch)
tree2165a9f837ba679614dad3204869669a9feafd2b
downloadaur-5c9fd6e36785fabcdfb2445912941279044a1949.tar.gz
first commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD74
-rw-r--r--config45
3 files changed, 142 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9ec8de3249de
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = wpa_supplicant-openssl-1.0
+ pkgdesc = A utility providing key negotiation for WPA wireless networks (with openssl-1.0)
+ pkgver = 2.8
+ pkgrel = 1
+ url = http://hostap.epitest.fi/wpa_supplicant
+ arch = x86_64
+ license = GPL
+ depends = openssl-1.0
+ depends = libdbus
+ depends = readline
+ depends = libnl
+ provides = wpa_supplicant
+ conflicts = wpa_supplicant
+ source = https://w1.fi/releases/wpa_supplicant-2.8.tar.gz
+ source = https://w1.fi/releases/wpa_supplicant-2.8.tar.gz.asc
+ source = config
+ validpgpkeys = EC4AA0A991A5F2464582D52D2B6EF432EFC895FA
+ sha256sums = a689336a12a99151b9de5e25bfccadb88438f4f4438eb8db331cd94346fd3d96
+ sha256sums = SKIP
+ sha256sums = 23aee0597750ec21b37654b5163e2f577c1204fc33bdfbf7bc2fb470e8a467db
+
+pkgname = wpa_supplicant-openssl-1.0
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d93570138b2a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,74 @@
+# Maintainer: David Wu <xdavidwuph@gmail.com>
+# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
+# Contributor: Thomas Bächler <thomas@archlinux.org>
+pkgname=wpa_supplicant-openssl-1.0
+_pkgname=wpa_supplicant
+pkgver=2.8
+pkgrel=1
+pkgdesc='A utility providing key negotiation for WPA wireless networks (with openssl-1.0)'
+url='http://hostap.epitest.fi/wpa_supplicant'
+arch=(x86_64)
+license=(GPL)
+depends=(openssl-1.0 libdbus readline libnl)
+provides=(wpa_supplicant)
+conflicts=(wpa_supplicant)
+source=(https://w1.fi/releases/${_pkgname}-${pkgver}.tar.gz{,.asc}
+ config
+)
+validpgpkeys=('EC4AA0A991A5F2464582D52D2B6EF432EFC895FA') # Jouni Malinen
+sha256sums=('a689336a12a99151b9de5e25bfccadb88438f4f4438eb8db331cd94346fd3d96'
+ 'SKIP'
+ '23aee0597750ec21b37654b5163e2f577c1204fc33bdfbf7bc2fb470e8a467db')
+
+prepare() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ local i; for i in "${source[@]}"; do
+ case $i in
+ *.patch)
+ msg2 "Applying patch $i"
+ patch -p1 -i "$srcdir/$i"
+ ;;
+ esac
+ done
+
+ cd "$srcdir/$_pkgname-$pkgver/$_pkgname"
+ cp "$srcdir/config" ./.config
+}
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver/$_pkgname"
+
+ export CFLAGS="$CPPFLAGS $CFLAGS -I/usr/include/openssl-1.0"
+ export LIBS="-L/usr/lib/openssl-1.0"
+ export LIBS_p="-L/usr/lib/openssl-1.0"
+
+ make LIBDIR=/usr/lib BINDIR=/usr/bin
+ make LIBDIR=/usr/lib BINDIR=/usr/bin eapol_test
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver/$_pkgname"
+ make LIBDIR=/usr/lib BINDIR=/usr/bin DESTDIR="$pkgdir" install
+ install -Dm755 eapol_test "$pkgdir/usr/bin/eapol_test"
+
+ install -d -m755 "$pkgdir/etc/wpa_supplicant"
+ install -Dm644 wpa_supplicant.conf \
+ "$pkgdir/usr/share/doc/wpa_supplicant/wpa_supplicant.conf"
+
+
+ install -d -m755 "$pkgdir/usr/share/dbus-1/system-services"
+ install -m644 \
+ dbus/fi.w1.wpa_supplicant1.service \
+ "$pkgdir/usr/share/dbus-1/system-services/"
+
+ install -Dm644 dbus/dbus-wpa_supplicant.conf \
+ "$pkgdir/etc/dbus-1/system.d/wpa_supplicant.conf"
+
+ install -d -m755 "$pkgdir/usr/share/man/man"{5,8}
+ install -m644 doc/docbook/*.5 "$pkgdir/usr/share/man/man5/"
+ install -m644 doc/docbook/*.8 "$pkgdir/usr/share/man/man8/"
+ rm -f "$pkgdir/usr/share/man/man8/wpa_"{priv,gui}.8
+
+ install -d -m755 "$pkgdir/usr/lib/systemd/system"
+ install -m644 systemd/*.service "$pkgdir/usr/lib/systemd/system/"
+}
diff --git a/config b/config
new file mode 100644
index 000000000000..8815d16934bd
--- /dev/null
+++ b/config
@@ -0,0 +1,45 @@
+CONFIG_AP=y
+CONFIG_AUTOSCAN_EXPONENTIAL=y
+CONFIG_AUTOSCAN_PERIODIC=y
+CONFIG_BACKEND=file
+CONFIG_BGSCAN_SIMPLE=y
+CONFIG_CTRL_IFACE=y
+CONFIG_CTRL_IFACE_BUS=y
+CONFIG_CTRL_IFACE_DBUS_INTRO=y
+CONFIG_CTRL_IFACE_DBUS_NEW=y
+CONFIG_DEBUG_FILE=y
+CONFIG_DRIVER_NL80211=y
+CONFIG_DRIVER_WEXT=y
+CONFIG_DRIVER_WIRED=y
+CONFIG_EAP_FAST=y
+CONFIG_EAP_GTC=y
+CONFIG_EAP_LEAP=y
+CONFIG_EAP_MD5=y
+CONFIG_EAP_MSCHAPV2=y
+CONFIG_EAP_OTP=y
+CONFIG_EAP_PEAP=y
+CONFIG_EAP_PWD=y
+CONFIG_EAP_TLS=y
+CONFIG_EAP_TTLS=y
+CONFIG_HS20=y
+CONFIG_HT_OVERRIDES=y
+CONFIG_IBSS_RSN=y
+CONFIG_IEEE80211AC=y
+CONFIG_IEEE80211N=y
+CONFIG_IEEE80211R=y
+CONFIG_IEEE80211W=y
+CONFIG_IEEE8021X_EAPOL=y
+CONFIG_INTERWORKING=y
+CONFIG_IPV6=y
+CONFIG_LIBNL32=y
+CONFIG_NO_RANDOM_POOL=y
+CONFIG_P2P=y
+CONFIG_PEERKEY=y
+CONFIG_PKCS12=y
+CONFIG_READLINE=y
+CONFIG_SMARTCARD=y
+CONFIG_TDLS=y
+CONFIG_VHT_OVERRIDES=y
+CONFIG_WIFI_DISPLAY=y
+CONFIG_WPS=y
+CONFIG_WPS_NFC=y