summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRomain Bazile2016-12-26 20:12:35 +0100
committerRomain Bazile2016-12-26 20:12:35 +0100
commit383e7f14de0690f5c884ba39613a7ffed190bbf0 (patch)
tree1a3ae13175db246d29122fa65b57557d3775000b
downloadaur-383e7f14de0690f5c884ba39613a7ffed190bbf0.tar.gz
First release for wpantund-git
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD33
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2a5568d93baa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = wpantund-git
+ pkgdesc = Userspace WPAN Network Daemon
+ pkgver = 0.07.00.r222.g811cef1
+ pkgrel = 1
+ url = https://github.com/openthread/wpantund
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ makedepends = gcc
+ makedepends = boost-libs
+ makedepends = readline
+ depends = dbus
+ depends = readline
+ provides = wpantund
+ provides = wpanctl
+ source = wpantund-git::git+https://github.com/openthread/wpantund.git
+ sha512sums = SKIP
+
+pkgname = wpantund-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01090786b221
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Romain Bazile <gromain.baz at gmail dot com>
+pkgname=wpantund-git
+pkgver=0.07.00.r222.g811cef1
+pkgrel=1
+pkgdesc="Userspace WPAN Network Daemon"
+arch=('i686' 'x86_64')
+url="https://github.com/openthread/wpantund"
+license=('Apache')
+makedepends=('git' 'gcc' 'boost-libs' 'readline')
+depends=('dbus' 'readline')
+provides=('wpantund' 'wpanctl')
+source=("$pkgname::git+https://github.com/openthread/wpantund.git")
+
+sha512sums=('SKIP')
+
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd $pkgname
+ ./bootstrap.sh
+ ./configure --sysconfdir=/etc
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+