summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordeviantfero2017-08-13 20:31:57 -0600
committerdeviantfero2017-08-13 20:31:57 -0600
commitad145575f55f5f1075fda8b85c55bf28ed54a7f9 (patch)
tree6dc0904cfaa496f343361751c4f7ca18668130e3
parent8138ca30139e10bdd7077e277547721ee0347189 (diff)
downloadaur-ad145575f55f5f1075fda8b85c55bf28ed54a7f9.tar.gz
move to using pywal package
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD31
2 files changed, 12 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d6e9b4a0371..06b22659a637 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
pkgbase = wpgtk-git
pkgdesc = A gui wallpaper chooser that changes your Openbox theme, GTK theme and Tint2 theme
- pkgver = r247.1610c3f
+ pkgver = r335.0a7756f
pkgrel = 1
url = https://github.com/deviantfero/wpgtk
arch = any
- license = MIT
- makedepends = git
+ license = GPLv2
depends = python
depends = python-pillow
- depends = feh
depends = python-gobject
depends = gtk3
depends = libxslt
+ depends = python-pywal
provides = wpgtk
conflicts = wpgtk
- source = git://github.com/deviantfero/wpgtk#branch=testing
+ source = git://github.com/deviantfero/wpgtk#branch=master
sha512sums = SKIP
pkgname = wpgtk-git
diff --git a/PKGBUILD b/PKGBUILD
index dc6d0114a2a5..07571e12598b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,18 +2,17 @@
_gitname=wpgtk
pkgname="${_gitname}-git"
-_gitbranch=testing
+_gitbranch=master
_gitauthor=deviantfero # deviantfero
-pkgver=r247.1610c3f
+pkgver=r335.0a7756f
pkgrel=1
pkgdesc="A gui wallpaper chooser that changes your Openbox theme, GTK theme and Tint2 theme"
url="https://github.com/${_gitauthor}/${_gitname}"
-license=('MIT')
+license=('GPLv2')
source=("git://github.com/${_gitauthor}/${_gitname}#branch=${_gitbranch}")
sha512sums=('SKIP')
arch=('any')
-depends=('python' 'python-pillow' 'feh' 'python-gobject' 'gtk3' 'libxslt')
-makedepends=('git')
+depends=('python' 'python-pillow' 'python-gobject' 'gtk3' 'libxslt' 'python-pywal')
optdepends=()
conflicts=("${_gitname}")
provides=("${_gitname}")
@@ -27,22 +26,8 @@ pkgver() {
package() {
cd "${srcdir}/${_gitname}"
- wget https://raw.githubusercontent.com/deviantfero/wal/master/wal
- mkdir -p ${pkgdir}/usr/bin/wpgtk/py
- mkdir -p ${pkgdir}/usr/bin/wpgtk/gui
- mkdir -p ${pkgdir}/usr/bin/wpgtk/data
- install -D -m755 ./wpgtk/wpg.py ${pkgdir}/usr/bin/wpgtk/
- install -D -m755 ./wpgtk/gui/* ${pkgdir}/usr/bin/wpgtk/gui/
- install -D -m755 ./wpgtk/data/* ${pkgdir}/usr/bin/wpgtk/data/
- install -D -m775 ./wpg ${pkgdir}/usr/bin/wpg
- install -D -m775 ./wal ${pkgdir}/usr/bin/wal
- rm ./wal
- bash ./installaur.sh
- echo
- echo "Remember to add sh ~/.wallpapers/wp_init.sh"
- echo "to your startup programs"
- echo
- echo "To run just type wpg"
- echo
- sleep 3
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ install -Dm644 "$srcdir/$_gitname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/$_gitname/$_gitname/misc/wpg.conf" \
+ "$pkgdir/etc/$_gitname/wpg.conf"
}