summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Veness2023-07-23 13:35:39 -0700
committerTyler Veness2023-07-23 13:35:39 -0700
commit24d13b64f316f4726f214953689b6b213717a141 (patch)
tree5a14660e4ba476e666af1e260d0022c5146e1138
parent4bf4889a368ef37c532977b1c6705922ff635f7f (diff)
downloadaur-24d13b64f316f4726f214953689b6b213717a141.tar.gz
Fix build failures with GCC 13
-rw-r--r--.SRCINFO8
-rw-r--r--Add-missing-include.patch13
-rw-r--r--Don_t-treat-warnings-as-errors.patch12
-rw-r--r--PKGBUILD11
-rw-r--r--Suppress-Eigen-warning.patch15
5 files changed, 37 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0a1c5a55cb1..065cc9967b56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wpimath
pkgdesc = WPILib's mathematics and controls library
pkgver = 2023.4.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/wpilibsuite/allwpilib
arch = x86_64
license = BSD
@@ -12,8 +12,10 @@ pkgbase = wpimath
options = !strip
options = staticlibs
source = git+https://github.com/wpilibsuite/allwpilib#tag=v2023.4.3
- source = Suppress-Eigen-warning.patch
+ source = Don_t-treat-warnings-as-errors.patch
+ source = Add-missing-include.patch
md5sums = SKIP
- md5sums = 0116ecb4c78683a00db29f15c23b2920
+ md5sums = 06355c12d930efa26edbbe11f633831a
+ md5sums = e2b9acf67122eca03efd62866a54ba59
pkgname = wpimath
diff --git a/Add-missing-include.patch b/Add-missing-include.patch
new file mode 100644
index 000000000000..f08bb4e941f8
--- /dev/null
+++ b/Add-missing-include.patch
@@ -0,0 +1,13 @@
+diff --git a/wpiutil/src/main/native/include/wpi/Base64.h b/wpiutil/src/main/native/include/wpi/Base64.h
+index c410bd0c26..858ff73fff 100644
+--- a/wpiutil/src/main/native/include/wpi/Base64.h
++++ b/wpiutil/src/main/native/include/wpi/Base64.h
+@@ -5,6 +5,8 @@
+ #ifndef WPIUTIL_WPI_BASE64_H_
+ #define WPIUTIL_WPI_BASE64_H_
+
++#include <stdint.h>
++
+ #include <cstddef>
+ #include <span>
+ #include <string>
diff --git a/Don_t-treat-warnings-as-errors.patch b/Don_t-treat-warnings-as-errors.patch
new file mode 100644
index 000000000000..9d65f0a649f5
--- /dev/null
+++ b/Don_t-treat-warnings-as-errors.patch
@@ -0,0 +1,12 @@
+diff --git a/cmake/modules/CompileWarnings.cmake b/cmake/modules/CompileWarnings.cmake
+index 93b35b8abf..bf00ad1d3a 100644
+--- a/cmake/modules/CompileWarnings.cmake
++++ b/cmake/modules/CompileWarnings.cmake
+@@ -1,6 +1,6 @@
+ macro(wpilib_target_warnings target)
+ if(NOT MSVC)
+- target_compile_options(${target} PRIVATE -Wall -pedantic -Wextra -Werror -Wno-unused-parameter ${WPILIB_TARGET_WARNINGS})
++ target_compile_options(${target} PRIVATE -Wall -pedantic -Wextra -Wno-unused-parameter ${WPILIB_TARGET_WARNINGS})
+ else()
+ target_compile_options(${target} PRIVATE /wd4146 /wd4244 /wd4251 /wd4267 /WX /D_CRT_SECURE_NO_WARNINGS ${WPILIB_TARGET_WARNINGS})
+ endif()
diff --git a/PKGBUILD b/PKGBUILD
index b329c536bf1c..035463978a71 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=wpimath
pkgver=2023.4.3
-pkgrel=2
+pkgrel=3
pkgdesc="WPILib's mathematics and controls library"
arch=('x86_64')
url='https://github.com/wpilibsuite/allwpilib'
@@ -11,13 +11,16 @@ makedepends=('cmake')
license=('BSD' 'MIT')
options=('!strip' 'staticlibs')
source=('git+https://github.com/wpilibsuite/allwpilib#tag=v2023.4.3'
- 'Suppress-Eigen-warning.patch')
+ 'Don_t-treat-warnings-as-errors.patch'
+ 'Add-missing-include.patch')
md5sums=('SKIP'
- '0116ecb4c78683a00db29f15c23b2920')
+ '06355c12d930efa26edbbe11f633831a'
+ 'e2b9acf67122eca03efd62866a54ba59')
prepare() {
cd allwpilib
- patch -p1 < "$srcdir"/Suppress-Eigen-warning.patch
+ patch -p1 < "$srcdir"/Don_t-treat-warnings-as-errors.patch
+ patch -p1 < "$srcdir"/Add-missing-include.patch
}
build() {
diff --git a/Suppress-Eigen-warning.patch b/Suppress-Eigen-warning.patch
deleted file mode 100644
index dc450512e281..000000000000
--- a/Suppress-Eigen-warning.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --git a/wpimath/src/main/native/include/frc/controller/LinearPlantInversionFeedforward.h b/wpimath/src/main/native/include/frc/controller/LinearPlantInversionFeedforward.h
-index d4cc3c426..bbf9a30a1 100644
---- a/wpimath/src/main/native/include/frc/controller/LinearPlantInversionFeedforward.h
-+++ b/wpimath/src/main/native/include/frc/controller/LinearPlantInversionFeedforward.h
-@@ -7,7 +7,10 @@
- #include <array>
- #include <functional>
-
-+#pragma GCC diagnostic push
-+#pragma GCC diagnostic ignored "-Warray-bounds"
- #include "Eigen/QR"
-+#pragma GCC diagnostic pop
- #include "frc/EigenCore.h"
- #include "frc/system/Discretization.h"
- #include "frc/system/LinearSystem.h"