summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchannel-422021-03-11 11:13:19 +0100
committerchannel-422021-03-11 11:13:19 +0100
commit65c0f4f1f3111e78deb549408b448c93ea215e52 (patch)
tree45407475844ced5dadbd24f4a458cfa99ab2759c
downloadaur-65c0f4f1f3111e78deb549408b448c93ea215e52.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec5ebe1f347f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wppfzf
+ pkgdesc = Browse and download images from reddit with fzf
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/channel-42/wppfzf
+ arch = any
+ groups = misc
+ license = GPL3
+ depends = fzf
+ depends = ueberzug
+ depends = bash
+ source = https://github.com/channel-42/wppfzf/archive/v0.1.0.tar.gz
+ md5sums = ef6561e2c7ec658108ccbf6f406ae96a
+
+pkgname = wppfzf
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e5b3756872b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: channel-42 <info@devls.de>
+# Maintainer: corusm <dev@corusm.de>
+pkgname=wppfzf
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Browse and download images from reddit with fzf"
+arch=('any')
+url="https://github.com/channel-42/wppfzf"
+license=('GPL3')
+groups=('misc')
+depends=('fzf'
+ 'ueberzug'
+ 'bash')
+source=("https://github.com/channel-42/$pkgname/archive/v$pkgver.tar.gz")
+md5sums=('ef6561e2c7ec658108ccbf6f406ae96a')
+
+package() {
+ cd "$pkgname-$pkgver"
+ make PREFIX="/usr" DESTDIR="$pkgdir/" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.md "$pkgdir/usr/share/doc/$pkgname/README.md"
+}
+
+# vim: ts=2 sw=2 et ft=PKGBUILD: