summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortippfehlr2024-03-01 20:20:14 +0100
committertippfehlr2024-03-01 20:20:14 +0100
commit9864f82ec12fa73f9e2d1edd14e4d5d05ce3377b (patch)
treebe9b2d8267fe7ba5985344596fa49ce39ae4a6b3
parentbb3155b793f6e4b20cbfd6a6ac58bab8d195bbbe (diff)
downloadaur-9864f82ec12fa73f9e2d1edd14e4d5d05ce3377b.tar.gz
v1.6.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD20
2 files changed, 21 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cef1c0e06573..16edc5e51d0a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = wrestic-bin
- pkgdesc = A wrapper around restic build in rust
- pkgver = 1.3.0
+ pkgdesc = A wrapper around restic built in rust
+ pkgver = 1.6.0
pkgrel = 1
url = https://github.com/alvaro17f/wrestic
arch = x86_64
- license = LGPL3
+ license = LGPL-3.0-only
provides = wrestic
conflicts = wrestic
- source = https://github.com/alvaro17f/wrestic/releases/download/v1.3.0/wrestic.tar.gz
- sha256sums = d95bdb3e885fbf7763337f69a80bf99ee8985a7791908c6c789a683400a23d4a
+ source = wrestic-1.6.0::https://github.com/alvaro17f/wrestic/releases/download/v1.6.0/wrestic.tar.gz
+ sha256sums = cfd91e2060c15ef5c66dacb6bb0f370017074e0822ee8ba763867af14cef2463
pkgname = wrestic-bin
diff --git a/PKGBUILD b/PKGBUILD
index cb84cebc7a24..fad7302bafe6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,17 +2,29 @@
_pkgname=wrestic
pkgname=wrestic-bin
-pkgver=1.3.0
+pkgver=1.6.0
pkgrel=1
pkgdesc='A wrapper around restic built in rust'
arch=('x86_64')
url="https://github.com/alvaro17f/$_pkgname"
-license=('LGPL3')
+license=('LGPL-3.0-only')
provides=('wrestic')
conflicts=('wrestic')
-source=("$url/releases/download/v$pkgver/$_pkgname.tar.gz")
-sha256sums=('d95bdb3e885fbf7763337f69a80bf99ee8985a7791908c6c789a683400a23d4a')
+source=("$_pkgname-$pkgver::$url/releases/download/v$pkgver/$_pkgname.tar.gz")
+sha256sums=('cfd91e2060c15ef5c66dacb6bb0f370017074e0822ee8ba763867af14cef2463')
+
+build() {
+ cd $srcdir
+ # completions
+ for shell in bash zsh fish; do
+ ./$_pkgname completions $shell >$shell-completion
+ done
+}
package() {
install -Dm755 "$srcdir/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+
+ install -Dm644 "$srcdir/bash-completion" "$pkgdir/usr/share/bash-completion/completions/$_pkgname"
+ install -Dm644 "$srcdir/zsh-completion" "$pkgdir/usr/share/zsh/site-functions/_$_pkgname"
+ install -Dm644 "$srcdir/fish-completion" "$pkgdir/usr/share/fish/vendor_completions.d/$_pkgname.fish"
}