summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolas Koesling2022-10-01 17:06:02 +0200
committerNikolas Koesling2022-10-01 17:06:02 +0200
commit713bedccc8a31c1dcd294eb4ed6a2e21b343d654 (patch)
tree0447811f8c8368c185ac50c35b8527f42ad476c2
downloadaur-713bedccc8a31c1dcd294eb4ed6a2e21b343d654.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD32
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16c56d3ae355
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = write-shm
+ pkgdesc = Write to a shared memory
+ pkgver = 0.1.3
+ pkgrel = 1
+ url = https://github.com/NikolasK-source/write_shm
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = cmake
+ makedepends = git
+ source = git+https://github.com/NikolasK-source/write_shm.git#tag=v0.1.3
+ sha256sums = SKIP
+
+pkgname = write-shm
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c6492656cc0d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Nikolas Koesling <nikolas@koesling.network>
+
+pkgname=write-shm
+pkgrel=1
+pkgver=0.1.3
+pkgdesc="Write to a shared memory"
+url="https://github.com/NikolasK-source/write_shm"
+license=('MIT')
+arch=('x86_64' 'aarch64')
+makedepends=('cmake' 'git')
+source=("git+https://github.com/NikolasK-source/write_shm.git#tag=v${pkgver}")
+
+sha256sums=('SKIP')
+
+prepare() {
+ cd write_shm
+ git submodule init
+ git submodule update
+ mkdir -p build
+ cmake -DCMAKE_BUILD_TYPE=Release -DCLANG_FORMAT=OFF -DCOMPILER_WARNINGS=OFF -B build .
+}
+
+build() {
+ cd write_shm
+ cmake --build build
+}
+
+package() {
+ cd write_shm
+ install -Dm755 build/write-shm "${pkgdir}/usr/bin/write-shm"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}