summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNikolas Koesling2024-04-01 14:09:37 +0200
committerNikolas Koesling2024-04-01 14:09:37 +0200
commitffccaec47faf7a18b2db2e42c0d7519e5f0d79d1 (patch)
treea9778c2bb7dda6915996f6449091b1d4c02e17d8
parentec78ebd9762d948749f221f13b7f0c4b67b57915 (diff)
downloadaur-ffccaec47faf7a18b2db2e42c0d7519e5f0d79d1.tar.gz
update to 1.1.0
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD7
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6983b1164b42..a96a82e598bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = write-shm
pkgdesc = Write to a shared memory
- pkgver = 1.0.0
+ pkgver = 1.1.0
pkgrel = 1
url = https://github.com/NikolasK-source/write_shm
arch = x86_64
@@ -8,7 +8,12 @@ pkgbase = write-shm
license = MIT
makedepends = cmake
makedepends = git
- source = git+https://github.com/NikolasK-source/write_shm.git#tag=v1.0.0
+ makedepends = cxxopts
+ makedepends = cxxshm
+ makedepends = cxxsemaphore
+ depends = cxxshm
+ depends = cxxsemaphore
+ source = git+https://github.com/NikolasK-source/write_shm.git#tag=v1.1.0
sha256sums = SKIP
pkgname = write-shm
diff --git a/PKGBUILD b/PKGBUILD
index 8e7b6bbe97c0..68e73e245ef8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,13 @@
pkgname=write-shm
pkgrel=1
-pkgver=1.0.0
+pkgver=1.1.0
pkgdesc="Write to a shared memory"
url="https://github.com/NikolasK-source/write_shm"
license=('MIT')
arch=('x86_64' 'aarch64')
-makedepends=('cmake' 'git')
+makedepends=('cmake' 'git' 'cxxopts' 'cxxshm' 'cxxsemaphore')
+depends=('cxxshm' 'cxxsemaphore')
source=("git+https://github.com/NikolasK-source/write_shm.git#tag=v${pkgver}")
sha256sums=('SKIP')
@@ -17,7 +18,7 @@ prepare() {
git submodule init
git submodule update
mkdir -p build
- cmake -DCMAKE_BUILD_TYPE=Release -DCLANG_FORMAT=OFF -DCOMPILER_WARNINGS=OFF -B build .
+ cmake -DCMAKE_BUILD_TYPE=Release -DCLANG_FORMAT=OFF -DCOMPILER_WARNINGS=OFF -DCLANG_TIDY=OFF -B build .
}
build() {