summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAdam Goldsmith2020-07-07 13:04:34 -0400
committerAdam Goldsmith2020-07-07 13:04:34 -0400
commit90f917632148179ad405df06291a52408d642c7b (patch)
treefc308e43fc7f6781b103d0086adeee97335de67d
parentfc7aecb18a807e421ef739f632d4f22d40583638 (diff)
downloadaur-90f917632148179ad405df06291a52408d642c7b.tar.gz
Bump version to 300
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 29 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 070aafe29012..9fdd82d530f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
-# Generated by mksrcinfo v8
-# Mon Jul 24 15:36:21 UTC 2017
pkgbase = write_stylus
pkgdesc = Write(orignal name) - A word processor for handwriting
- pkgver = 209
- pkgrel = 4
+ pkgver = 300
+ pkgrel = 1
url = http://www.styluslabs.com/
arch = i686
arch = x86_64
license = custom
- depends = qt5-svg
- source = http://www.styluslabs.com/write/write209.tar.gz
+ makedepends = desktop-file-utils
+ depends = sdl2
+ noextract = eula.docx
+ source = http://www.styluslabs.com/write/write300.tar.gz
source = http://www.styluslabs.com/write/eula.docx
- source = Write.desktop
- md5sums = 57f46eb04a251dabe0b25358cd47e31d
+ md5sums = 154302a3e32e22233c2cfd4ba048da42
md5sums = fafaef86844ead59b3837a5909bf780f
- md5sums = eddac9bb586cab9610eb72e030578622
pkgname = write_stylus
diff --git a/PKGBUILD b/PKGBUILD
index 073270e0d11e..a64cb1c2e6e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,36 @@
# Maintainer: Adam Goldsmith <contact@adamgoldsmith.name>
# Former Maintainer: Janosch Dobler <janosch.dobler [at} gmx [dot} de>
+
pkgname=write_stylus
-pkgver=209
-pkgrel=4
+pkgver=300
+pkgrel=1
pkgdesc="Write(orignal name) - A word processor for handwriting"
arch=(i686 x86_64)
url="http://www.styluslabs.com/"
license=('custom')
-depends=(qt5-svg)
+depends=(sdl2)
+makedepends=(desktop-file-utils)
source=("http://www.styluslabs.com/write/write${pkgver}.tar.gz"
- "http://www.styluslabs.com/write/eula.docx"
- "Write.desktop")
-md5sums=('57f46eb04a251dabe0b25358cd47e31d'
- 'fafaef86844ead59b3837a5909bf780f'
- 'eddac9bb586cab9610eb72e030578622')
+ "http://www.styluslabs.com/write/eula.docx")
+md5sums=('154302a3e32e22233c2cfd4ba048da42'
+ 'fafaef86844ead59b3837a5909bf780f')
+noextract=("eula.docx")
+
+prepare() {
+ desktop-file-edit --set-key=Exec --set-value=/usr/bin/write_stylus "$srcdir/Write/Write.desktop"
+ desktop-file-edit --set-key=Icon --set-value=/usr/share/icons/hicolor/144x144/apps/write_stylus.png "$srcdir/Write/Write.desktop"
+}
package() {
- install -Dm755 "$srcdir/Write/Write" "$pkgdir/usr/bin/write_stylus"
+ install -Dm755 "$srcdir/Write/Write" "$pkgdir/usr/local/write_stylus/Write"
+ install -m644 "$srcdir/Write/"{DroidSansFallback.ttf,Intro.svg,Roboto-Regular.ttf} "$pkgdir/usr/local/write_stylus/"
+
+ install -dm755 "$pkgdir/usr/bin/"
+ ln -s /usr/local/write_stylus/Write "$pkgdir/usr/bin/write_stylus"
+
install -Dm644 "$srcdir/eula.docx" "$pkgdir/usr/share/licenses/write_stylus/eula.docx"
- install -Dm644 "$srcdir/Write.desktop" "$pkgdir/usr/share/applications/Write.desktop"
+ install -Dm644 "$srcdir/Write/Write.desktop" "$pkgdir/usr/share/applications/Write.desktop"
+ install -Dm644 "$srcdir/Write/Write144x144.png" "$pkgdir/usr/share/icons/hicolor/144x144/apps/write_stylus.png"
}
# vim:set ts=2 sw=2 et: