summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Whited2019-07-02 09:24:26 -0500
committerSam Whited2019-07-02 09:24:26 -0500
commitc26acab746362fd1a74af99ae8ce976efb917c3c (patch)
tree7316c88a181fe0631eb9c95aaee347e07c4403a4
parentb2c0d3ae6a276ca1103750c8312647a4fd89fb09 (diff)
downloadaur-c26acab746362fd1a74af99ae8ce976efb917c3c.tar.gz
Bump to v0.10.0
-rw-r--r--.SRCINFO12
-rw-r--r--64.patch64
-rw-r--r--PKGBUILD12
-rw-r--r--makefile.patch38
4 files changed, 50 insertions, 76 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ec9656c328b..d3862abc729d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = writefreely
pkgdesc = Federated blogging from write.as
- pkgver = 0.9.1
- pkgrel = 2
+ pkgver = 0.10.0
+ pkgrel = 1
url = https://writefreely.org/
install = writefreely.install
arch = x86_64
@@ -18,13 +18,13 @@ pkgbase = writefreely
source = writefreely-sysusers.conf
source = writefreely.service
source = config.ini
- source = 64.patch
- source = https://github.com/writeas/writefreely/archive/v0.9.1.tar.gz
+ source = makefile.patch
+ source = https://github.com/writeas/writefreely/archive/v0.10.0.tar.gz
sha256sums = 6c74c81e27165851daf20d4bcf958227342f063aa3ec53b1cb86a56dac565f10
sha256sums = 60d4b49872523a2aed3e0e6a55513dfefe5ae6cbec43f2fcc65db894fb3bd2a3
sha256sums = e357b687bd0eab95996711276216b6f2dc534ba9214ae094172d6d7a6b1fdae5
- sha256sums = 009c083488511d92b489337f7feb8bd17631a104907959d21b1f9b5df3ce0a70
- sha256sums = 547261d5ad015dfae079dbd197b7b17e365d23611c8ae60e0e554c34202df9e6
+ sha256sums = f6282ce91ada86b77f54469f0c24db20089b87bf4593ee23f5855cbf5fde4859
+ sha256sums = 7ba4208ece3c6e94573e1acb89506b3dd803ec10b98f291d72a372d032b326a6
pkgname = writefreely
diff --git a/64.patch b/64.patch
deleted file mode 100644
index b66787104d6a..000000000000
--- a/64.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-From f9335a8fe9378b8013a27875085a5e19f0c0670a Mon Sep 17 00:00:00 2001
-From: Sam Whited <sam@samwhited.com>
-Date: Wed, 9 Jan 2019 12:00:10 -0600
-Subject: [PATCH] respect external $LDFLAGS on build
-
----
- Makefile | 28 ++++++++++++++++++++--------
- 1 file changed, 20 insertions(+), 8 deletions(-)
-
-diff --git a/Makefile b/Makefile
-index 5950dfd..b05a747 100644
---- a/Makefile
-+++ b/Makefile
-@@ -1,10 +1,22 @@
--GITREV=`git describe --tags | cut -c 2-`
--LDFLAGS=-ldflags="-X 'github.com/writeas/writefreely.softwareVer=$(GITREV)'"
-+# make(1) from NetBSD (bmake on many Linux's) uses $(.CURDIR), but GNU Make uses
-+# $(CURDIR). Normalize on $(.CURDIR) by setting it to $(CURDIR) if not set, and
-+# then $(PWD) if still not set.
-+.CURDIR ?= $(CURDIR)
-+.CURDIR ?= $(PWD)
-+
-+# For reproducible builds, don't store the current build directory by default;
-+# instead store only the path from the root of the repo (so there is still
-+# enough info in debug messages to find the correct file).
-+GCFLAGS = -gcflags="all=-trimpath=$(.CURDIR)"
-+ASMFLAGS = -asmflags="all=-trimpath=$(.CURDIR)"
-+
-+GITREV!=git describe --tags | cut -c 2-
-+GOLDFLAGS=-ldflags="-X 'github.com/writeas/writefreely.softwareVer=$(GITREV)' -extldflags '$(LDFLAGS)'"
-
- GOCMD=go
--GOINSTALL=$(GOCMD) install $(LDFLAGS)
--GOBUILD=$(GOCMD) build $(LDFLAGS)
--GOTEST=$(GOCMD) test $(LDFLAGS)
-+GOINSTALL=$(GOCMD) install $(GOLDFLAGS) $(GCFLAGS) $(ASMFLAGS)
-+GOBUILD=$(GOCMD) build $(GOLDFLAGS) $(GCFLAGS) $(ASMFLAGS)
-+GOTEST=$(GOCMD) test $(GOLDFLAGS) $(GCFLAGS) $(ASMFLAGS)
- GOGET=$(GOCMD) get
- BINARY_NAME=writefreely
- DOCKERCMD=docker
-@@ -19,19 +31,19 @@ build-linux: deps
- @hash xgo > /dev/null 2>&1; if [ $$? -ne 0 ]; then \
- $(GOGET) -u github.com/karalabe/xgo; \
- fi
-- xgo --targets=linux/amd64, -dest build/ $(LDFLAGS) -tags='sqlite' -out writefreely ./cmd/writefreely
-+ xgo --targets=linux/amd64, -dest build/ $(GOLDFLAGS) $(GCFLAGS) $(ASMFLAGS) -tags='sqlite' -out writefreely ./cmd/writefreely
-
- build-windows: deps
- @hash xgo > /dev/null 2>&1; if [ $$? -ne 0 ]; then \
- $(GOGET) -u github.com/karalabe/xgo; \
- fi
-- xgo --targets=windows/amd64, -dest build/ $(LDFLAGS) -tags='sqlite' -out writefreely ./cmd/writefreely
-+ xgo --targets=windows/amd64, -dest build/ $(GOLDFLAGS) $(GCFLAGS) $(ASMFLAGS) -tags='sqlite' -out writefreely ./cmd/writefreely
-
- build-darwin: deps
- @hash xgo > /dev/null 2>&1; if [ $$? -ne 0 ]; then \
- $(GOGET) -u github.com/karalabe/xgo; \
- fi
-- xgo --targets=darwin/amd64, -dest build/ $(LDFLAGS) -tags='sqlite' -out writefreely ./cmd/writefreely
-+ xgo --targets=darwin/amd64, -dest build/ $(GOLDFLAGS) $(GCFLAGS) $(ASMFLAGS) -tags='sqlite' -out writefreely ./cmd/writefreely
-
- build-docker :
- $(DOCKERCMD) build -t $(IMAGE_NAME):latest -t $(IMAGE_NAME):$(GITREV) .
diff --git a/PKGBUILD b/PKGBUILD
index 40ef303a2169..5f25c2ab1842 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: Sam Whited <sam@samwhited.com>
pkgname=writefreely
-pkgver=0.9.1
-pkgrel=2
+pkgver=0.10.0
+pkgrel=1
pkgdesc='Federated blogging from write.as'
arch=('x86_64')
url='https://writefreely.org/'
@@ -20,19 +20,19 @@ install=writefreely.install
source=(writefreely-sysusers.conf
writefreely.service
config.ini
- 64.patch
+ makefile.patch
"https://github.com/writeas/writefreely/archive/v${pkgver}.tar.gz")
sha256sums=('6c74c81e27165851daf20d4bcf958227342f063aa3ec53b1cb86a56dac565f10'
'60d4b49872523a2aed3e0e6a55513dfefe5ae6cbec43f2fcc65db894fb3bd2a3'
'e357b687bd0eab95996711276216b6f2dc534ba9214ae094172d6d7a6b1fdae5'
- '009c083488511d92b489337f7feb8bd17631a104907959d21b1f9b5df3ce0a70'
- '547261d5ad015dfae079dbd197b7b17e365d23611c8ae60e0e554c34202df9e6')
+ 'f6282ce91ada86b77f54469f0c24db20089b87bf4593ee23f5855cbf5fde4859'
+ '7ba4208ece3c6e94573e1acb89506b3dd803ec10b98f291d72a372d032b326a6')
prepare() {
export GO111MODULE=on
cd "${srcdir}/${pkgname}-${pkgver}/"
- patch -p1 <../64.patch
+ patch -p1 Makefile ../makefile.patch
}
build() {
diff --git a/makefile.patch b/makefile.patch
new file mode 100644
index 000000000000..9755325a23af
--- /dev/null
+++ b/makefile.patch
@@ -0,0 +1,38 @@
+1,2c1,14
+< GITREV=`git describe | cut -c 2-`
+< LDFLAGS=-ldflags="-X 'github.com/writeas/writefreely.softwareVer=$(GITREV)'"
+---
+> # make(1) from NetBSD (bmake on many Linux's) uses $(.CURDIR), but GNU Make uses
+> # $(CURDIR). Normalize on $(.CURDIR) by setting it to $(CURDIR) if not set, and
+> # then $(PWD) if still not set.
+> .CURDIR ?= $(CURDIR)
+> .CURDIR ?= $(PWD)
+>
+> # For reproducible builds, don't store the current build directory by default;
+> # instead store only the path from the root of the repo (so there is still
+> # enough info in debug messages to find the correct file).
+> GCFLAGS = -gcflags="all=-trimpath=$(.CURDIR)"
+> ASMFLAGS = -asmflags="all=-trimpath=$(.CURDIR)"
+>
+> GITREV!=git describe --tags | cut -c 2-
+> GOLDFLAGS=-ldflags="-X 'github.com/writeas/writefreely.softwareVer=$(GITREV)' -extldflags '$(LDFLAGS)'"
+5,7c17,19
+< GOINSTALL=$(GOCMD) install $(LDFLAGS)
+< GOBUILD=$(GOCMD) build $(LDFLAGS)
+< GOTEST=$(GOCMD) test $(LDFLAGS)
+---
+> GOINSTALL=$(GOCMD) install $(GOLDFLAGS) $(GCFLAGS) $(ASMFLAGS)
+> GOBUILD=$(GOCMD) build $(GOLDFLAGS) $(GCFLAGS) $(ASMFLAGS)
+> GOTEST=$(GOCMD) test $(GOLDFLAGS) $(GCFLAGS) $(ASMFLAGS)
+29c41
+< xgo --targets=linux/amd64, -dest build/ $(LDFLAGS) -tags='sqlite' -out writefreely ./cmd/writefreely
+---
+> xgo --targets=linux/amd64, -dest build/ $(GOLDFLAGS) -tags='sqlite' -out writefreely ./cmd/writefreely
+35c47
+< xgo --targets=windows/amd64, -dest build/ $(LDFLAGS) -tags='sqlite' -out writefreely ./cmd/writefreely
+---
+> xgo --targets=windows/amd64, -dest build/ $(GOLDFLAGS) -tags='sqlite' -out writefreely ./cmd/writefreely
+41c53
+< xgo --targets=darwin/amd64, -dest build/ $(LDFLAGS) -tags='sqlite' -out writefreely ./cmd/writefreely
+---
+> xgo --targets=darwin/amd64, -dest build/ $(GOLDFLAGS) -tags='sqlite' -out writefreely ./cmd/writefreely