summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Coffin2019-06-14 14:53:57 -0600
committerMatt Coffin2019-06-14 16:03:53 -0600
commit73802dac3065393c013354936a4c39154d24a6a7 (patch)
tree9bb56b7c705130f792b8a5c3375ae94accc93e86
downloadaur-73802dac3065393c013354936a4c39154d24a6a7.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD55
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..65253f3fac8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wsa-git
+ pkgdesc = GPUOpen-Drivers Window System Agent
+ pkgver = r8.f558403
+ pkgrel = 1
+ url = https://github.com/GPUOpen-Drivers/wsa
+ arch = x86_64
+ license = custom
+ makedepends = git
+ makedepends = cmake
+ makedepends = ninja
+ provides = wsa
+ conflicts = wsa
+ source = wsa::git+https://github.com/GPUOpen-Drivers/wsa.git
+ sha256sums = SKIP
+
+pkgname = wsa-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8005659b10b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# The following guidelines are specific to BZR, GIT, HG and SVN packages.
+# Other VCS sources are not natively supported by makepkg yet.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=wsa-git
+pkgver=r8.f558403
+pkgrel=1
+pkgdesc="GPUOpen-Drivers Window System Agent"
+arch=('x86_64')
+url="https://github.com/GPUOpen-Drivers/wsa"
+license=('custom')
+groups=()
+depends=()
+makedepends=('git' 'cmake' 'ninja') # 'bzr', 'git', 'mercurial' or 'subversion'
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('wsa::git+https://github.com/GPUOpen-Drivers/wsa.git')
+noextract=()
+sha256sums=('SKIP')
+
+# Please refer to the 'USING VCS SOURCES' section of the PKGBUILD man page for
+# a description of each element in the source array.
+
+pkgver() {
+ cd "$srcdir/wsa"
+
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/wsa"
+ cmake \
+ -B build \
+ -G Ninja \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ .
+ ninja -C build
+}
+
+package() {
+ cd "$srcdir/wsa"
+ DESTDIR="$pkgdir" ninja -C build install
+ cd "$pkgdir"
+ mv usr/lib64 usr/lib
+}