summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorredtide2024-03-04 23:48:36 +0100
committerredtide2024-03-04 23:48:36 +0100
commit0e898a5dd7d2606ccc1d280a2b160c918c7cef66 (patch)
tree2f295368d120803f2c94a38c3d8077d87e56a138
parentf3a6e576ab86e166b8b03fe704b123b5b42cdcbc (diff)
downloadaur-0e898a5dd7d2606ccc1d280a2b160c918c7cef66.tar.gz
CMake build
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD25
2 files changed, 19 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7aee9ed14fcc..cdff2b12fa06 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = wshot-git
pkgdesc = Screenshot GUI for wayland
- pkgver = 1.0.3.r0.gdd54aff
+ pkgver = 1.0.2.r21.ga302158
pkgrel = 1
- url = https://github.com/stefonarch/wshot
+ url = https://github.com/qtilities/wshot
arch = any
license = GPL3
makedepends = git
@@ -12,7 +12,7 @@ pkgbase = wshot-git
depends = jq
provides = wshot
conflicts = wshot
- source = git+https://github.com/stefonarch/wshot
+ source = git+https://github.com/qtilities/wshot
sha512sums = SKIP
pkgname = wshot-git
diff --git a/PKGBUILD b/PKGBUILD
index 77cd8ed67dd0..5d324566f785 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
_pkgname=wshot
pkgname=$_pkgname-git
-pkgver=1.0.3.r0.gdd54aff
+pkgver=1.0.2.r21.ga302158
pkgrel=1
pkgdesc="Screenshot GUI for wayland"
arch=(any)
-url="https://github.com/stefonarch/$_pkgname"
+url="https://github.com/qtilities/wshot"
license=(GPL3)
source=(git+$url)
sha512sums=(
@@ -26,17 +26,24 @@ depends=(
pkgver() {
cd $_pkgname
- ( set -o pipefail
+ (
+ set -o pipefail
git describe --long --tags 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
)
}
+build() {
+ local cmake_options=(
+ -B build
+ -D CMAKE_INSTALL_PREFIX=/usr
+ -S $_pkgname
+ -W no-dev
+ )
+ cmake "${cmake_options[@]}"
+ cmake --build build --verbose
+}
+
package() {
- cd "$srcdir"/$_pkgname
- install -vDm 755 $_pkgname -t "$pkgdir"/usr/bin/
- install -vDm 644 $_pkgname.desktop -t "$pkgdir"/usr/share/applications/
- install -vDm 644 $_pkgname.png -t "$pkgdir"/usr/share/pixmaps/
- install -vDm 644 README.md -t "$pkgdir"/usr/share/doc/$_pkgname/
- install -vDm 644 wshot1.png -t "$pkgdir"/usr/share/doc/$_pkgname/
+ DESTDIR="$pkgdir" cmake --install build
}