summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormatheuz12102021-08-30 21:24:59 -0300
committermatheuz12102021-08-30 21:24:59 -0300
commit2bd3c61de2759f6b5186c9d506348e5368e451b4 (patch)
treef97b9866e25d4f1254f29d0380e390ba649a4158
downloadaur-2bd3c61de2759f6b5186c9d506348e5368e451b4.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2b3c3add62fb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = wsid-git
+ pkgdesc = web show image directory
+ pkgver = 0.1.r3.43c968c
+ pkgrel = 1
+ url = https://github.com/matheuz1210/wsid
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = python>=3.9
+ optdepends = python-pyqt5: for gui
+ source = wsid::git+https://github.com/matheuz1210/wsid
+ b2sums = SKIP
+
+pkgname = wsid-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f71c635dafda
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1909eed1f2cb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: matheuz1210 <matheuz1210 at gmail dot com>
+
+pkgname=wsid-git
+pkgver=0.1.r3.43c968c
+pkgrel=1
+pkgdesc='web show image directory'
+arch=(any)
+url='https://github.com/matheuz1210/wsid'
+license=(GPL)
+depends=(
+ 'python>=3.9' )
+makedepends=(
+ git )
+optdepends=(
+ 'python-pyqt5: for gui' )
+source=(
+ "${pkgname%-git}::git+${url}" )
+b2sums=(SKIP)
+
+pkgver(){
+ cd "${srcdir}/${pkgname%-git}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+package(){
+ cd "${srcdir}/${pkgname%-git}"
+ install -Dm755 wsid -t "${pkgdir}/usr/bin"
+}