summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormatheuz12102021-08-31 19:57:01 -0300
committermatheuz12102021-08-31 19:57:01 -0300
commit8d8f761210cc6d072690f357a3e68088aaf03a71 (patch)
tree8e15ca48e390227a97ac3f8707e8910b8cc4be89
parent2bd3c61de2759f6b5186c9d506348e5368e451b4 (diff)
downloadaur-8d8f761210cc6d072690f357a3e68088aaf03a71.tar.gz
build it as a python module
-rw-r--r--PKGBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1909eed1f2cb..cf1279c56c07 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: matheuz1210 <matheuz1210 at gmail dot com>
pkgname=wsid-git
-pkgver=0.1.r3.43c968c
+pkgver=0.3.r0.313eb8d
pkgrel=1
pkgdesc='web show image directory'
arch=(any)
@@ -22,7 +22,12 @@ pkgver(){
printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
+build(){
+ cd "${srcdir}/${pkgname%-git}"
+ python - build <<<"from setuptools import setup; setup()"
+}
+
package(){
cd "${srcdir}/${pkgname%-git}"
- install -Dm755 wsid -t "${pkgdir}/usr/bin"
+ python - install --root="${pkgdir}" --optimize=1 --skip-build <<<"from setuptools import setup; setup()"
}