summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Gatzweiler2015-06-09 15:33:45 +0200
committerThomas Gatzweiler2015-06-09 15:33:45 +0200
commitafaad4a129cf0cb74493c38f782026156a6afd92 (patch)
treed6c3fc3bdc9e6851f45eef1ad91c55ada572cef4
downloadaur-afaad4a129cf0cb74493c38f782026156a6afd92.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD34
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0dde02596b53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wsjtx-bin
+ pkgdesc = Software for Amateur Radio Weak-Signal Communication (JT9 and JT65)
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = http://physics.princeton.edu/pulsar/k1jt/wsjtx.html
+ arch = i686
+ arch = x86_64
+ license = GPL-3
+ depends = qt5-base
+ depends = qt5-multimedia
+ depends = qt5-serialport
+ depends = libusb
+ depends = libusb-compat
+ depends = kvasd-bin
+ source = http://physics.princeton.edu/pulsar/k1jt/wsjtx_1.5.0_i386.deb
+ md5sums = c3e3fe2351cebf1f81133de140d8ff6c
+
+pkgname = wsjtx-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb49e9057f37
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Thomas Gatzweiler <thomas.gatzweiler@gmail.com>
+
+pkgname=wsjtx-bin
+pkgver=1.5.0
+pkgrel=1
+pkgdesc="Software for Amateur Radio Weak-Signal Communication (JT9 and JT65)"
+arch=(i686 x86_64)
+url="http://physics.princeton.edu/pulsar/k1jt/wsjtx.html"
+license=("GPL-3")
+depends=(qt5-base qt5-multimedia qt5-serialport libusb libusb-compat kvasd-bin)
+makedepends=()
+
+if [ "$CARCH" == "x86_64" ]; then
+ debfile="wsjtx_1.5.0_amd64.deb"
+ md5sums=(19c56e6a2dd273eaf3d6125933cb6381)
+else
+ debfile="wsjtx_1.5.0_i386.deb"
+ md5sums=(c3e3fe2351cebf1f81133de140d8ff6c)
+fi
+
+source=("http://physics.princeton.edu/pulsar/k1jt/${debfile}")
+
+prepare() {
+ cd "$srcdir"
+ ar vx $debfile
+}
+
+package() {
+ cd "$srcdir"
+ tar -C ${pkgdir}/ -xvf data.tar.gz
+ cd "$pkgdir"
+ chmod 755 usr/ usr/share/ usr/bin/ usr/share/doc/
+ chmod 755 usr/share/applications/ usr/share/pixmaps/
+}