summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeal Miller2018-06-15 17:00:35 -0500
committerNeal Miller2018-06-15 17:00:35 -0500
commit471d8c3267c24aa265a4cc8f03045896e04ab29a (patch)
tree2420718c6ad1466efb09afaa29e2d1c5dcb4acc1
downloadaur-471d8c3267c24aa265a4cc8f03045896e04ab29a.tar.gz
Initial release of wsjtx (superbuild-git version) on the AUR
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD35
-rw-r--r--wsjtx.patch23
3 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..207fcb19d5f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = wsjtx-superbuild-git
+ pkgdesc = Software for Amateur Radio Weak-Signal Communication (JT9 and JT65) -- Superbuild / git version -- Will build hamlib so it is not required as a dependent
+ pkgver = r30.1967f54
+ pkgrel = 1
+ url = http://physics.princeton.edu/pulsar/k1jt/wsjtx.html
+ arch = i686
+ arch = x86_64
+ license = GPL-3
+ makedepends = cmake
+ makedepends = git
+ makedepends = asciidoc
+ depends = qt5-base
+ depends = qt5-multimedia
+ depends = qt5-serialport
+ depends = libusb
+ depends = libusb-compat
+ depends = fftw
+ depends = gcc-fortran
+ provides = wsjtx
+ conflicts = wsjtx
+ source = git+https://git.code.sf.net/p/wsjt/wsjtx-superbuild/
+ source = wsjtx.patch
+ md5sums = SKIP
+ md5sums = c5a2c0b91c2709e070d7ebcb75621354
+
+pkgname = wsjtx-superbuild-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8e83cea7c635
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Neal Miller <ac9qd@protonmail.com>
+
+pkgname=wsjtx-superbuild-git
+pkgver=r30.1967f54
+pkgrel=1
+pkgdesc='Software for Amateur Radio Weak-Signal Communication (JT9 and JT65) -- Superbuild / git version -- Will build hamlib so it is not required as a dependent'
+arch=('i686' 'x86_64')
+url='http://physics.princeton.edu/pulsar/k1jt/wsjtx.html'
+license=('GPL-3')
+depends=('qt5-base' 'qt5-multimedia' 'qt5-serialport' 'libusb' 'libusb-compat' 'fftw' 'gcc-fortran')
+makedepends=('cmake' 'git' 'asciidoc')
+provides=('wsjtx')
+conflicts=('wsjtx')
+source=('git+https://git.code.sf.net/p/wsjt/wsjtx-superbuild/'
+ 'wsjtx.patch')
+md5sums=('SKIP'
+ 'c5a2c0b91c2709e070d7ebcb75621354')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cp wsjtx.patch "$srcdir/${pkgname%-git}"
+ mkdir -p "$srcdir/${pkgname%-git}/build"
+ cd "$srcdir/${pkgname%-git}/build"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}/build"
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/wsjtx.patch b/wsjtx.patch
new file mode 100644
index 000000000000..9b8e043ab3dd
--- /dev/null
+++ b/wsjtx.patch
@@ -0,0 +1,23 @@
+diff -ur /CMakeLists.txt /CMakeLists.txt
+--- /CMakeLists.txt 2018-05-31 02:29:47.000000000 +0200
++++ /CMakeLists.txt 2018-06-03 09:34:15.109877528 +0200
+@@ -1343,7 +1343,8 @@
+ )
+ endif ()
+ endif ()
+-qt5_use_modules (wsjtx SerialPort) # not sure why the interface link library syntax above doesn't work
++find_package (Qt5SerialPort)
++target_link_libraries (wsjtx Qt5::SerialPort)
+
+ # make a library for WSJT-X UDP servers
+ # add_library (wsjtx_udp SHARED ${UDP_library_CXXSRCS})
+@@ -1364,7 +1365,8 @@
+ )
+ target_compile_definitions (wsjtx_udp-static PUBLIC UDP_STATIC_DEFINE)
+ #qt5_use_modules (wsjtx_udp Network)
+-qt5_use_modules (wsjtx_udp-static Network Gui)
++target_link_libraries (wsjtx_udp-static Qt5::Network Qt5::Gui)
++
+ generate_export_header (wsjtx_udp-static BASE_NAME udp)
+
+ add_executable (udp_daemon UDPExamples/UDPDaemon.cpp UDPExamples/udp_daemon.rc ${WSJTX_ICON_FILE})