summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNeal Miller2019-01-11 20:11:16 -0600
committerNeal Miller2019-01-11 20:11:16 -0600
commit65ac26ba39eb765c7bace4aaa175fb3f0d74fc51 (patch)
tree91c67ee94d9f7d93a68909a53b877e6699c1ff06
parent0a420e1c8cd0d2400332b2dbb8f79f75e96f1977 (diff)
downloadaur-65ac26ba39eb765c7bace4aaa175fb3f0d74fc51.tar.gz
Add patch to change to working WSJTX repo on SourceForge
-rw-r--r--PKGBUILD11
-rw-r--r--repo.patch11
2 files changed, 18 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 510b480dfe68..294374189655 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: Neal Miller <ac9qd@protonmail.com>
pkgname=wsjtx-superbuild-git
-pkgver=r32.bce3bea
+pkgver=r35.491536f
pkgrel=1
pkgdesc='Software for Amateur Radio Weak-Signal Communication (JT9 and JT65) - Superbuild/git version, hamlib not required'
arch=('i686' 'x86_64')
url='http://physics.princeton.edu/pulsar/k1jt/wsjtx.html'
license=('GPL-3')
depends=('qt5-base' 'qt5-multimedia' 'qt5-serialport' 'libusb' 'libusb-compat' 'fftw' 'gcc-fortran')
-makedepends=('cmake' 'git' 'asciidoc')
+makedepends=('cmake' 'git' 'asciidoc' 'asciidoctor')
provides=('wsjtx')
conflicts=('wsjtx')
source=('git+https://git.code.sf.net/p/wsjt/wsjtx-superbuild/'
- 'wsjtx.patch')
+ 'wsjtx.patch'
+ 'repo.patch')
md5sums=('SKIP'
- 'c5a2c0b91c2709e070d7ebcb75621354')
+ 'c5a2c0b91c2709e070d7ebcb75621354'
+ 'd7446a4c8d44880b1c772493a7f170c6')
#set branch to build with WSJTX_TAG variable, or a specific version eg. wsjtx-1.9.0
_wsjtx_tag=master
@@ -24,6 +26,7 @@ pkgver() {
}
build() {
+ patch -p1 -i repo.patch
cp wsjtx.patch "$srcdir/${pkgname%-git}"
mkdir -p "$srcdir/${pkgname%-git}/build"
cd "$srcdir/${pkgname%-git}/build"
diff --git a/repo.patch b/repo.patch
new file mode 100644
index 000000000000..dee33a7dbd04
--- /dev/null
+++ b/repo.patch
@@ -0,0 +1,11 @@
+--- /wsjtx-superbuild/CMakeLists.txt 2019-01-11 19:45:51.092696936 -0600
++++ /wsjtx-superbuild/CMakeLists.txt 2019-01-11 19:40:06.127327712 -0600
+@@ -50,7 +50,7 @@
+ # one day this needs to change to the hamlib git master
+ set (hamlib_repo git://git.code.sf.net/u/bsomervi/hamlib)
+
+- set (wsjtx_repo git@bitbucket.org:k1jt/wsjtx.git)
++ set (wsjtx_repo git://git.code.sf.net/p/wsjt/wsjtx)
+
+ # one day this needs to change to master or some agreed stable SHA
+ set (hamlib_TAG integration)