summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Feuls2015-06-30 13:01:41 +0200
committerCarsten Feuls2015-06-30 13:01:41 +0200
commita58b1dddb96a88b716c8f07c212c6b666d1a851c (patch)
tree373ad5b09b69ba0d94e43e5d7e64b0db1b01e288
downloadaur-a58b1dddb96a88b716c8f07c212c6b666d1a851c.tar.gz
Initial Commit
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD67
-rw-r--r--padevsub.c.patch18
-rw-r--r--wspr-svn.desktop16
-rw-r--r--wspr-svn.pngbin0 -> 378 bytes
-rw-r--r--wspr.py.patch11
6 files changed, 140 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bf244f55680e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = wspr-svn
+ pkgdesc = Weak Signal Propagation Reporter
+ pkgver = 2460
+ pkgrel = 3
+ url = http://physics.princeton.edu/pulsar/K1JT/wspr.html
+ arch = x86_64
+ arch = i686
+ arch = armv5h
+ arch = armv6h
+ arch = armv7h
+ license = GPL
+ makedepends = subversion
+ depends = python2
+ depends = python-imaging
+ depends = python2-numpy
+ depends = libsamplerate
+ depends = portaudio
+ depends = fftw
+ depends = gcc-fortran
+ source = padevsub.c.patch
+ source = wspr-svn.png
+ source = wspr-svn.desktop
+ sha512sums = 6e774feb45b327a10da759e476960344314e894d1aa0e9c7d1b11fda092d82b4c629e04ef58b46a273f184c60a526c434160004f77fbe9f38304d1099f327451
+ sha512sums = 9fb794b5cd645e816ea72e9e12d5cbe8e95d3782ff290d92c40266a7ac17d212c9465e84b32f2bab23d3e45456d0f1456ff39ebf869eb544a4cc88c85cf64102
+ sha512sums = 71a813e21d5299a7efec3081cfc08dcb024dc72542eaba7a5ced52323ebbdfe1b09bbdfd2a270f85067d49c8d7091e8c0ff94c28a2f0f74ed8ec0a6b38f1b396
+
+pkgname = wspr-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e065662cb29b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Maintainer: Carsten DL1CAF <archlinux at carstenfeuls dot de>
+# Submitter: Mike WB2FKO <mph at sportscliche dot com>
+# Contributor: minorsecond <minorsecond at gmail dot com>
+pkgname=wspr-svn
+pkgver=2460
+pkgrel=3
+pkgdesc="Weak Signal Propagation Reporter"
+arch=('x86_64' 'i686' 'armv5h' 'armv6h' 'armv7h')
+url="http://physics.princeton.edu/pulsar/K1JT/wspr.html"
+license=('GPL')
+depends=('python2' 'python-imaging' 'python2-numpy' 'libsamplerate' 'portaudio' 'fftw' 'gcc-fortran')
+makedepends=('subversion')
+source=(padevsub.c.patch
+ $pkgname.png
+ $pkgname.desktop)
+sha512sums=('6e774feb45b327a10da759e476960344314e894d1aa0e9c7d1b11fda092d82b4c629e04ef58b46a273f184c60a526c434160004f77fbe9f38304d1099f327451'
+ '9fb794b5cd645e816ea72e9e12d5cbe8e95d3782ff290d92c40266a7ac17d212c9465e84b32f2bab23d3e45456d0f1456ff39ebf869eb544a4cc88c85cf64102'
+ '71a813e21d5299a7efec3081cfc08dcb024dc72542eaba7a5ced52323ebbdfe1b09bbdfd2a270f85067d49c8d7091e8c0ff94c28a2f0f74ed8ec0a6b38f1b396')
+
+_svntrunk="svn://svn.code.sf.net/p/wsjt/wsjt/branches/wspr"
+_svnmod="wspr"
+
+build() {
+# Set the build environment to python2
+ export PYTHON="/usr/bin/python2"
+ export F2PY="/usr/bin/python2 f2py.py"
+ unset LDFLAGS
+ cd "$srcdir"
+
+ if [ -d $_svnmod/.svn ]; then
+ (cd $_svnmod && svn up -r $pkgver)
+ else
+ svn co $_svntrunk --config-dir ./ -r $pkgver $_svnmod
+ fi
+
+ msg "SVN checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_svnmod-build"
+ cp -r "$srcdir/$_svnmod" "$srcdir/$_svnmod-build"
+ cd "$srcdir/$_svnmod-build"
+
+# Make problems can sometimes be fixed by replacing g95 with gfortran
+ ./configure --prefix=/usr --enable-gcc-fortran
+ patch -p0 < ${srcdir}/padevsub.c.patch
+ make
+
+}
+
+package() {
+ cd "$srcdir/$_svnmod-build"
+ rm -rf build/
+ python2 setup.py install --root=$pkgdir/
+ sed -i 's:python -O wspr.py:python2 -O /usr/bin/wspr.py:' wspr
+ install -Dm755 wspr $pkgdir/usr/bin/wspr
+
+# Install a menu item with icon
+ cd $srcdir
+ mkdir -p $pkgdir/usr/share/pixmaps
+ mkdir -p $pkgdir/usr/share/applications
+ mkdir -p $pkgdir/usr/share/doc/$pkgname
+ install -Dm644 $pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 $pkgname.png $pkgdir/usr/share/pixmaps/$pkgname.png
+ cp -ra $srcdir/$_svnmod-build/*.TXT $pkgdir/usr/share/doc/$pkgname/
+ cd "${pkgdir}/usr/bin"
+}
+
diff --git a/padevsub.c.patch b/padevsub.c.patch
new file mode 100644
index 000000000000..735ca0142181
--- /dev/null
+++ b/padevsub.c.patch
@@ -0,0 +1,18 @@
+--- padevsub.c.orig 2015-01-17 14:27:48.000000000 -0500
++++ padevsub.c 2015-01-17 14:30:28.000000000 -0500
+@@ -99,8 +99,14 @@
+ //outerr[i] = Pa_IsFormatSupported(NULL,&outputParameters,SAMPLE_RATE);
+ outerr[i] = 0;
+ }
+- fprintf(fp,"%2d %3d %3d %6d %6d %s\n",i,nchin[i],nchout[i],inerr[i],
++ if (pdi->name == NULL) {
++ fprintf(stderr, "Bad Joe. BAD BAD BAD\n");
++ fprintf(fp,"%2d %3d %3d %6d %6d %s\n",i,nchin[i],nchout[i],inerr[i],
++ outerr[i],"{NULL}");
++ } else {
++ fprintf(fp,"%2d %3d %3d %6d %6d %s\n",i,nchin[i],nchout[i],inerr[i],
+ outerr[i],pdi->name);
++ }
+ }
+ fclose(fp);
+ return 0; \ No newline at end of file
diff --git a/wspr-svn.desktop b/wspr-svn.desktop
new file mode 100644
index 000000000000..06630bd2b6da
--- /dev/null
+++ b/wspr-svn.desktop
@@ -0,0 +1,16 @@
+[Desktop Entry]
+Name=WSPR
+Name[en_US]=WSPR
+Comment=Weak Signal Propagation Reporter
+Comment[en_US]=Weak Signal Propagation Reporter
+Encoding=UTF-8
+Exec=wspr
+Icon=wspr-svn.png
+MimeType=text
+StartupNotify=true
+Terminal=
+TerminalOptions=
+Type=Application
+Categories=Application;HamRadio
+X-DCOP-ServiceType=none
+X-KDE-SubstituteUID=false
diff --git a/wspr-svn.png b/wspr-svn.png
new file mode 100644
index 000000000000..77b5a7d451b0
--- /dev/null
+++ b/wspr-svn.png
Binary files differ
diff --git a/wspr.py.patch b/wspr.py.patch
new file mode 100644
index 000000000000..3f8755372409
--- /dev/null
+++ b/wspr.py.patch
@@ -0,0 +1,11 @@
+--- wspr.py.orig 2015-01-22 19:32:59.000000000 +0100
++++ wspr.py 2015-01-22 19:43:27.133581716 +0100
+@@ -35,7 +35,7 @@
+ from Numeric import zeros
+ import array
+ import dircache
+-import Image, ImageTk, ImageDraw
++from PIL import Image, ImageTk, ImageDraw
+ from WsprMod.palettes import colormapblue, colormapgray0, colormapHot, \
+ colormapAFMHot, colormapgray1, colormapLinrad, Colormap2Palette
+ from types import * \ No newline at end of file