summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarsten Feuls2016-03-15 14:14:25 +0100
committerCarsten Feuls2016-03-15 14:14:25 +0100
commitbc19008776f1e0b932587b2536ee6a9affd0928a (patch)
tree3e83ff42411dd1be11a7d6cdf70f5e90aabd3b74
parenta58b1dddb96a88b716c8f07c212c6b666d1a851c (diff)
downloadaur-bc19008776f1e0b932587b2536ee6a9affd0928a.tar.gz
wspy.py.patch added
-rw-r--r--.SRCINFO4
-rw-r--r--.gitigore7
-rw-r--r--PKGBUILD5
-rw-r--r--wspr.py.patch28
4 files changed, 32 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf244f55680e..1674ad6666d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Tue Mar 15 13:13:58 UTC 2016
pkgbase = wspr-svn
pkgdesc = Weak Signal Propagation Reporter
pkgver = 2460
@@ -18,9 +20,11 @@ pkgbase = wspr-svn
depends = fftw
depends = gcc-fortran
source = padevsub.c.patch
+ source = wspr.py.patch
source = wspr-svn.png
source = wspr-svn.desktop
sha512sums = 6e774feb45b327a10da759e476960344314e894d1aa0e9c7d1b11fda092d82b4c629e04ef58b46a273f184c60a526c434160004f77fbe9f38304d1099f327451
+ sha512sums = 927622b5423d109812ae25ef3c43d1ce1ea5eea224f9a66f59acda1e559077276cf88181c53771d23f4dea4c5efbd5e3b6a43deef7dc5d007712335f07fb9718
sha512sums = 9fb794b5cd645e816ea72e9e12d5cbe8e95d3782ff290d92c40266a7ac17d212c9465e84b32f2bab23d3e45456d0f1456ff39ebf869eb544a4cc88c85cf64102
sha512sums = 71a813e21d5299a7efec3081cfc08dcb024dc72542eaba7a5ced52323ebbdfe1b09bbdfd2a270f85067d49c8d7091e8c0ff94c28a2f0f74ed8ec0a6b38f1b396
diff --git a/.gitigore b/.gitigore
new file mode 100644
index 000000000000..7254c747cc89
--- /dev/null
+++ b/.gitigore
@@ -0,0 +1,7 @@
+*
+!PKGBUILD
+!*.patch
+!.gitignore
+!.SRCINFO
+!*.desktop
+!*.png
diff --git a/PKGBUILD b/PKGBUILD
index e065662cb29b..cce16c197a05 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Carsten DL1CAF <archlinux at carstenfeuls dot de>
+# Maintainer: Carsten Feuls <archlinux at carstenfeuls dot de>
# Submitter: Mike WB2FKO <mph at sportscliche dot com>
# Contributor: minorsecond <minorsecond at gmail dot com>
pkgname=wspr-svn
@@ -11,9 +11,11 @@ license=('GPL')
depends=('python2' 'python-imaging' 'python2-numpy' 'libsamplerate' 'portaudio' 'fftw' 'gcc-fortran')
makedepends=('subversion')
source=(padevsub.c.patch
+ wspr.py.patch
$pkgname.png
$pkgname.desktop)
sha512sums=('6e774feb45b327a10da759e476960344314e894d1aa0e9c7d1b11fda092d82b4c629e04ef58b46a273f184c60a526c434160004f77fbe9f38304d1099f327451'
+ '927622b5423d109812ae25ef3c43d1ce1ea5eea224f9a66f59acda1e559077276cf88181c53771d23f4dea4c5efbd5e3b6a43deef7dc5d007712335f07fb9718'
'9fb794b5cd645e816ea72e9e12d5cbe8e95d3782ff290d92c40266a7ac17d212c9465e84b32f2bab23d3e45456d0f1456ff39ebf869eb544a4cc88c85cf64102'
'71a813e21d5299a7efec3081cfc08dcb024dc72542eaba7a5ced52323ebbdfe1b09bbdfd2a270f85067d49c8d7091e8c0ff94c28a2f0f74ed8ec0a6b38f1b396')
@@ -50,6 +52,7 @@ build() {
package() {
cd "$srcdir/$_svnmod-build"
rm -rf build/
+ patch -p0 < ${srcdir}/wspr.py.patch
python2 setup.py install --root=$pkgdir/
sed -i 's:python -O wspr.py:python2 -O /usr/bin/wspr.py:' wspr
install -Dm755 wspr $pkgdir/usr/bin/wspr
diff --git a/wspr.py.patch b/wspr.py.patch
index 3f8755372409..ee8a05f9c33b 100644
--- a/wspr.py.patch
+++ b/wspr.py.patch
@@ -1,11 +1,17 @@
---- wspr.py.orig 2015-01-22 19:32:59.000000000 +0100
-+++ wspr.py 2015-01-22 19:43:27.133581716 +0100
-@@ -35,7 +35,7 @@
- from Numeric import zeros
- import array
- import dircache
--import Image, ImageTk, ImageDraw
-+from PIL import Image, ImageTk, ImageDraw
- from WsprMod.palettes import colormapblue, colormapgray0, colormapHot, \
- colormapAFMHot, colormapgray1, colormapLinrad, Colormap2Palette
- from types import * \ No newline at end of file
++++ wspr.py 2016-03-15 14:10:21.385193623 +0100
+--- wspr.py.orig 2016-03-15 14:09:59.529132801 +0100
+@@ -30,12 +30,12 @@
+ from WsprMod import palettes
+ from math import log10
+ try:
+- from numpy.oldnumeric import zeros
++ from numpy import zeros
+ except:
+ from Numeric import zeros
+ import array
+ import dircache
+-import Image, ImageTk, ImageDraw
++from PIL import Image, ImageTk, ImageDraw
+ from WsprMod.palettes import colormapblue, colormapgray0, colormapHot, \
+ colormapAFMHot, colormapgray1, colormapLinrad, Colormap2Palette
+ from types import *