summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Guymer2017-03-27 21:00:06 +1000
committerSam Guymer2017-03-27 21:06:18 +1000
commit86fe1d707bc59f830cc16a19b8e112e4ef6b8489 (patch)
treef04ffab2fe00998651971b785a82b182acb5d598
downloadaur-86fe1d707bc59f830cc16a19b8e112e4ef6b8489.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD29
3 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..604e7e632bc2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wsta
+ pkgdesc = A CLI development tool for WebSocket APIs
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/esphen/wsta
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cargo
+ depends = openssl
+ source = https://github.com/esphen/wsta/archive/0.5.0.tar.gz
+ sha256sums = 97d277faf0a423910c74e1036df724f16362839196c56d0986de7db15d6ba629
+
+pkgname = wsta
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..197cf8471a0d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.tar.gz
+*.pkg.tar.xz
+
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9954a645b279
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Sam Guymer <sam at guymer dot me>
+
+pkgname=wsta
+pkgver=0.5.0
+pkgrel=1
+pkgdesc="A CLI development tool for WebSocket APIs"
+arch=("i686" "x86_64")
+url="https://github.com/esphen/wsta"
+license=("GPL3")
+depends=("openssl")
+makedepends=("cargo")
+source=("https://github.com/esphen/$pkgname/archive/$pkgver.tar.gz")
+sha256sums=("97d277faf0a423910c74e1036df724f16362839196c56d0986de7db15d6ba629")
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -D -m0755 target/release/wsta "$pkgdir/usr/bin/$pkgname"
+ install -D -m0644 wsta.1 "$pkgdir/usr/share/man/man1/$pkgname.1"
+ install -D -m0644 LICENCE "$pkgdir/usr/share/licenses/$pkgname/LICENCE"
+}
+
+# vim: ft=sh syn=sh