summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvlad2015-10-04 00:08:37 +0300
committervlad2015-10-04 00:08:37 +0300
commit593b7b018eaa77639841838c35cb65fdeb302388 (patch)
tree9ed05a146d8b6f14647c2627d78022a993dae0fc
downloadaur-593b7b018eaa77639841838c35cb65fdeb302388.tar.gz
initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD32
-rw-r--r--wtftw.install3
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3551f316136e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = wtftw
+ pkgdesc = Window Tiling For The Win. A tiling window manager written in Rust
+ pkgver = 1.2
+ pkgrel = 1
+ url = https://github.com/Kintaro/wtftw
+ install = wtftw.install
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = cargo
+ makedepends = git
+ depends = rust
+ depends = xorg-xmessage
+ source = https://github.com/Kintaro/wtftw/archive/1.2/wtftw-1.2.tar.gz
+ md5sums = 14bcf2a3a324a44ab494aaf3d3d8dd55
+
+pkgname = wtftw
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..307179575dc6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Vlad M. <vlad@archlinux.net>
+
+pkgname=wtftw
+pkgver=1.2
+pkgrel=1
+pkgdesc='Window Tiling For The Win. A tiling window manager written in Rust'
+arch=('i686' 'x86_64')
+url="https://github.com/Kintaro/wtftw"
+license=('custom')
+depends=('rust'
+ 'xorg-xmessage')
+makedepends=('cargo' 'git')
+install=wtftw.install
+source=("https://github.com/Kintaro/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+md5sums=('14bcf2a3a324a44ab494aaf3d3d8dd55')
+
+build() {
+ cd "$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 target/release/wtftw \
+ "${pkgdir}"/usr/bin/wtftw
+
+ install -D config/config.rs \
+ "${pkgdir}"/usr/share/wtftw/config.rs
+
+ install -D LICENSE \
+ "${pkgdir}"/usr/share/licenses/wtftw/LICENSE
+}
diff --git a/wtftw.install b/wtftw.install
new file mode 100644
index 000000000000..e074453074f8
--- /dev/null
+++ b/wtftw.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo 'After the first start, the config needs to be placed in ~/.wtftw/src/config.rs'
+}