summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-09-09 15:37:19 +0300
committerorhun2020-09-09 15:37:19 +0300
commita8bc63e757692c2d20a3753e1ee1e89b10b1ce67 (patch)
tree1d4e598c227af7aced430eacd4e5122b28fba42b
parent40f4ba76dc30fcb27ba6ce3827b177ec9e025779 (diff)
downloadaur-a8bc63e757692c2d20a3753e1ee1e89b10b1ce67.tar.gz
upgpkg: wtftw 1.2.1-1
upstream release
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD30
2 files changed, 18 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 127e86bb9f81..f25ca07593ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = wtftw
pkgdesc = Window Tiling For The Win. A tiling window manager written in Rust
- pkgver = 1.2
+ pkgver = 1.2.1
pkgrel = 1
- url = https://github.com/Kintaro/wtftw
+ url = https://github.com/orhun/wtftw
install = wtftw.install
- arch = i686
arch = x86_64
license = custom
makedepends = cargo
- depends = rust
depends = xorg-xmessage
- source = https://github.com/Kintaro/wtftw/archive/1.2/wtftw-1.2.tar.gz
- md5sums = 14bcf2a3a324a44ab494aaf3d3d8dd55
+ depends = libxinerama
+ source = wtftw-1.2.1.tar.gz::https://github.com/orhun/wtftw/archive/1.2.1.tar.gz
+ md5sums = fc937342074634cf348a7a1a6aa85bdc
pkgname = wtftw
diff --git a/PKGBUILD b/PKGBUILD
index 716bb73fa86d..73c2ee5951f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,28 @@
-# Maintainer: Vlad M. <vlad@archlinux.net>
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
pkgname=wtftw
-pkgver=1.2
+pkgver=1.2.1
pkgrel=1
pkgdesc='Window Tiling For The Win. A tiling window manager written in Rust'
-arch=('i686' 'x86_64')
-url="https://github.com/Kintaro/wtftw"
+arch=('x86_64')
+url="https://github.com/orhun/wtftw"
license=('custom')
-depends=('rust'
- 'xorg-xmessage')
+depends=('xorg-xmessage' 'libxinerama')
makedepends=('cargo')
install=wtftw.install
-source=("https://github.com/Kintaro/$pkgname/archive/$pkgver/$pkgname-$pkgver.tar.gz")
-md5sums=('14bcf2a3a324a44ab494aaf3d3d8dd55')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/$pkgver.tar.gz")
+md5sums=('fc937342074634cf348a7a1a6aa85bdc')
build() {
cd "$pkgname-$pkgver"
- cargo build --release
+ cargo build --release --all-features
}
package() {
cd "$pkgname-$pkgver"
- install -Dm755 target/release/wtftw \
- "${pkgdir}"/usr/bin/wtftw
-
- install -D config/config.rs \
- "${pkgdir}"/usr/share/wtftw/config.rs
-
- install -D LICENSE \
- "${pkgdir}"/usr/share/licenses/wtftw/LICENSE
+ install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm 644 config/config.rs -t "$pkgdir/usr/share/$pkgname"
}