summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authororhun2020-09-09 17:30:43 +0300
committerorhun2020-09-09 17:30:43 +0300
commit5107658c8a4e9ae5de7cece8367b40f46b5864b9 (patch)
tree5eefbeb3a7ce0bfbe4cc99d88732d57bb3efd9cf
parentd40953d56cea66ceb7fa9188945d11343515a2ec (diff)
downloadaur-5107658c8a4e9ae5de7cece8367b40f46b5864b9.tar.gz
upgpkg: wtftw-git 1:r347.14f3d1e-1
-rw-r--r--.SRCINFO11
-rw-r--r--LICENSE28
-rw-r--r--PKGBUILD41
3 files changed, 23 insertions, 57 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a23f8705792..9e2665235b27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wtftw-git
- pkgdesc = Window Tiling For The Win. A tiling window manager written in Rust
- pkgver = 1.2.r57.gebf5f9f
+ pkgdesc = Window Tiling For The Win. A tiling window manager written in Rust (git)
+ pkgver = r347.14f3d1e
pkgrel = 1
epoch = 1
url = https://github.com/Kintaro/wtftw
@@ -10,12 +10,11 @@ pkgbase = wtftw-git
license = custom
makedepends = cargo
makedepends = git
- depends = rust
depends = xorg-xmessage
- provides = wtftw
+ depends = libxinerama
conflicts = wtftw
- source = git+https://github.com/Kintaro/wtftw.git
- source = LICENSE
+ source = git+https://github.com/Kintaro/wtftw
+ source = wtftw-r347.14f3d1e-LICENSE::https://github.com/Kintaro/wtftw/raw/master/LICENSE
sha256sums = SKIP
sha256sums = d2fff178c328ba155cf3eddcdf7533c9aca0b415a4f748a251ea1c32656700a1
diff --git a/LICENSE b/LICENSE
deleted file mode 100644
index ffc2557d857d..000000000000
--- a/LICENSE
+++ /dev/null
@@ -1,28 +0,0 @@
-Copyright (c) 2014, Simon Wollwage
-All rights reserved.
-
-Redistribution and use in source and binary forms, with or without
-modification, are permitted provided that the following conditions are met:
-
-* Redistributions of source code must retain the above copyright notice, this
- list of conditions and the following disclaimer.
-
-* Redistributions in binary form must reproduce the above copyright notice,
- this list of conditions and the following disclaimer in the documentation
- and/or other materials provided with the distribution.
-
-* Neither the name of wtftw nor the names of its
- contributors may be used to endorse or promote products derived from
- this software without specific prior written permission.
-
-THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS "AS IS"
-AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE
-IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
-DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT HOLDER OR CONTRIBUTORS BE LIABLE
-FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
-DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
-CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY,
-OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
diff --git a/PKGBUILD b/PKGBUILD
index 8d1cb37aa0d5..24c226e3fa99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,40 @@
-# Maintainer: Frederic Bezies < fredbezies at gmail dot com >
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# Contributor: Frederic Bezies < fredbezies at gmail dot com >
# Contributor: Vlad M. <vlad@archlinux.net>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
+# https://github.com/orhun/pkgbuilds
pkgname=wtftw-git
-pkgver=1.2.r57.gebf5f9f
+pkgver=r347.14f3d1e
pkgrel=1
epoch=1
-pkgdesc='Window Tiling For The Win. A tiling window manager written in Rust'
+pkgdesc='Window Tiling For The Win. A tiling window manager written in Rust (git)'
arch=('i686' 'x86_64')
url="https://github.com/Kintaro/wtftw"
license=('custom')
-depends=('rust'
- 'xorg-xmessage')
+depends=('xorg-xmessage' 'libxinerama')
makedepends=('cargo' 'git')
-provides=('wtftw')
-conflicts=('wtftw')
install=wtftw.install
-source=('git+https://github.com/Kintaro/wtftw.git'
- 'LICENSE')
+conflicts=("${pkgname%-git}")
+source=("git+${url}"
+ "${pkgname%-git}-$pkgver-LICENSE::$url/raw/master/LICENSE")
sha256sums=('SKIP'
'd2fff178c328ba155cf3eddcdf7533c9aca0b415a4f748a251ea1c32656700a1')
pkgver() {
- cd wtftw
- git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- cd wtftw
- cargo build --release
+ cd "${pkgname%-git}"
+ cargo build --release --all-features
}
package() {
- cd wtftw
- install -Dm755 target/release/wtftw \
- "${pkgdir}"/usr/bin/wtftw
-
- install -D config/config.rs \
- "${pkgdir}"/usr/share/wtftw/config.rs
-
- install -D LICENSE \
- "${pkgdir}"/usr/share/licenses/wtftw/LICENSE
+ cd "${pkgname%-git}"
+ install -Dm 755 "target/release/${pkgname%-git}" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/${pkgname%-git}"
+ install -Dm 644 config/config.rs -t "$pkgdir/usr/share/${pkgname%-git}"
+ install -Dm 644 "../${pkgname%-git}-$pkgver-LICENSE" "$pkgdir/usr/share/licenses/${pkgname%-git}/LICENSE"
}
-