summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaio Augusto2019-09-19 01:02:12 -0300
committerKaio Augusto2019-09-19 01:02:12 -0300
commita502d5d7d17704146f9f58ae78f0b97e3dcf0360 (patch)
tree8abb4280e7cf8f27279c08f49fd8f2c984e0fe90
parente810d46e978963bb686e96a998a4d14927145c03 (diff)
downloadaur-a502d5d7d17704146f9f58ae78f0b97e3dcf0360.tar.gz
Bumped version to 0.22.0. Package is now properly built from the source!
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 34 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62c7b85f20a6..a679939b2320 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,16 @@
pkgbase = wtfutil
- pkgdesc = Personal information dashboard for your terminal
- pkgver = 0.4.0
- pkgrel = 1
- url = https://wtfutil.com
- arch = x86_64
- license = MIT
- source_x86_64 = https://github.com/senorprogrammer/wtf/releases/download/0.4.0/wtf_0.4.0_linux_amd64.tar.gz
- sha256sums_x86_64 = 1d2aa742f91e9b930d1fbf49278d1b10ac5a3670adca41a3648b757a7576f6fb
+ pkgdesc = Personal information dashboard for your terminal
+ pkgver = 0.22.0
+ pkgrel = 1
+ url = https://wtfutil.com
+ arch = i686
+ arch = x86_64
+ arch = aarch64
+ arch = armv6h
+ license = MPL2
+ makedepends = go-pie
+ source = wtfutil-0.22.0.tar.gz::https://github.com/wtfutil/wtf/archive/v0.22.0.tar.gz
+ sha256sums = b421af6aceba9b4f4ff67d591fd899e5357891a06fa13704ec4e77f983ee1064
pkgname = wtfutil
diff --git a/PKGBUILD b/PKGBUILD
index 1a868fc3cf42..fda902de3074 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,29 @@
-# Maintainer: Bruno Inec <bruno at inec dot fr>
+# Maintainer: Kaio "yaakushi" Augusto <kaioaugusto dot 8 at gmail dot com>
+# Contributor: yochananmarqos
+# Contributor: Bruno Inec <bruno at inec dot fr>
+
pkgname=wtfutil
-pkgver=0.4.0
+pkgver=0.22.0
pkgrel=1
pkgdesc="Personal information dashboard for your terminal"
-arch=(x86_64)
+arch=('i686' 'x86_64' 'aarch64' 'armv6h')
url="https://wtfutil.com"
-license=(MIT)
-source_x86_64=("https://github.com/senorprogrammer/wtf/releases/download/${pkgver}/wtf_${pkgver}_linux_amd64.tar.gz")
-sha256sums_x86_64=('1d2aa742f91e9b930d1fbf49278d1b10ac5a3670adca41a3648b757a7576f6fb')
+license=('MPL2')
+makedepends=('go-pie')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/wtfutil/wtf/archive/v$pkgver.tar.gz")
+sha256sums=('b421af6aceba9b4f4ff67d591fd899e5357891a06fa13704ec4e77f983ee1064')
+
+build() {
+ export GOPROXY="https://gocenter.io"
+
+ cd wtf-$pkgver
+ go build \
+ -trimpath \
+ -ldflags "-extldflags $LDFLAGS" \
+ -o $pkgname .
+}
package(){
- install -D "${srcdir}/wtf_${pkgver}_linux_amd64/wtf" "${pkgdir}/usr/bin/wtfutil"
+ cd wtf-$pkgver
+ install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
}