summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-05-09 10:13:29 -0600
committerMark Wagie2021-05-09 10:13:29 -0600
commita90df21f710f4c0e91e23f4ae39055ce747551ef (patch)
treed43f5268f7d3900fdd04f569fdeeb79cd0fa7dd3
parentc617d63dee5f0fdd503fb8441880170e1e8177de (diff)
downloadaur-a90df21f710f4c0e91e23f4ae39055ce747551ef.tar.gz
0.37.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD7
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 765e14a4bff5..6a2ff47bb9ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wtfutil
pkgdesc = Personal information dashboard for your terminal
- pkgver = 0.36.0
+ pkgver = 0.37.0
pkgrel = 1
url = https://wtfutil.com
arch = x86_64
@@ -9,8 +9,8 @@ pkgbase = wtfutil
license = MPL2
makedepends = go
depends = glibc
- source = wtfutil-0.36.0.tar.gz::https://github.com/wtfutil/wtf/archive/v0.36.0.tar.gz
- sha256sums = 6994cc1972d03b59d5c4a5028e9250fa9ec4c14856f902bcf7437339f01b141e
+ source = wtfutil-0.37.0.tar.gz::https://github.com/wtfutil/wtf/archive/v0.37.0.tar.gz
+ sha256sums = 84251f28691aaaa5c1dfcbb944bc41a97b5dcc14bc7c89000f6e7bc27366474b
pkgname = wtfutil
diff --git a/PKGBUILD b/PKGBUILD
index ebbd3ffb9f98..83c24a27fa73 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Bruno Inec <bruno at inec dot fr>
pkgname=wtfutil
-pkgver=0.36.0
+pkgver=0.37.0
pkgrel=1
pkgdesc="Personal information dashboard for your terminal"
arch=('x86_64' 'aarch64' 'armv6h')
@@ -13,9 +13,12 @@ license=('MPL2')
depends=('glibc')
makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::https://github.com/wtfutil/wtf/archive/v$pkgver.tar.gz")
-sha256sums=('6994cc1972d03b59d5c4a5028e9250fa9ec4c14856f902bcf7437339f01b141e')
+sha256sums=('84251f28691aaaa5c1dfcbb944bc41a97b5dcc14bc7c89000f6e7bc27366474b')
prepare() {
+ # Prevent creation of a `go` directory in one's home.
+ # Sometimes this directory cannot be removed with even `rm -rf` unless
+ # one becomes root or changes the write permissions.
export GOPATH="$srcdir/gopath"
go clean -modcache
}