summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-11-02 13:17:41 -0600
committerMark Wagie2021-11-02 13:17:41 -0600
commitaae01faca501474c70ddf2f6832c2d913a27f591 (patch)
treeef30d80ae95d6248405c459832cb4b5b699260b1
parent7cb012dfafda5aa894be3c8569b049e1ff8634ef (diff)
downloadaur-aae01faca501474c70ddf2f6832c2d913a27f591.tar.gz
0.40.0
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD27
2 files changed, 20 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9d5ba17bdf36..d7bbf92b52c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wtfutil
pkgdesc = Personal information dashboard for your terminal
- pkgver = 0.39.2
+ pkgver = 0.40.0
pkgrel = 1
url = https://wtfutil.com
arch = x86_64
@@ -9,7 +9,7 @@ pkgbase = wtfutil
license = MPL2
makedepends = go
depends = glibc
- source = wtfutil-0.39.2.tar.gz::https://github.com/wtfutil/wtf/archive/v0.39.2.tar.gz
- sha256sums = 6719bea25bd775a1f155729c13b2fc4e143eec32736b13f1240dcbb969528ac5
+ source = wtfutil-0.40.0.tar.gz::https://github.com/wtfutil/wtf/archive/v0.40.0.tar.gz
+ sha256sums = 74e29757fbaa9744e5707f6666195f21515f3abe29da284f833635afe60d12ec
pkgname = wtfutil
diff --git a/PKGBUILD b/PKGBUILD
index c5ec139494f8..4fa0acf08db2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Bruno Inec <bruno at inec dot fr>
pkgname=wtfutil
-pkgver=0.39.2
+pkgver=0.40.0
pkgrel=1
pkgdesc="Personal information dashboard for your terminal"
arch=('x86_64' 'aarch64' 'armv6h')
@@ -13,7 +13,7 @@ license=('MPL2')
depends=('glibc')
makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::https://github.com/wtfutil/wtf/archive/v$pkgver.tar.gz")
-sha256sums=('6719bea25bd775a1f155729c13b2fc4e143eec32736b13f1240dcbb969528ac5')
+sha256sums=('74e29757fbaa9744e5707f6666195f21515f3abe29da284f833635afe60d12ec')
prepare() {
# Prevent creation of a `go` directory in one's home.
@@ -25,21 +25,28 @@ prepare() {
build() {
cd "wtf-$pkgver"
- export CGO_CPPFLAGS="${CPPFLAGS}"
- export CGO_CFLAGS="${CFLAGS}"
- export CGO_CXXFLAGS="${CXXFLAGS}"
- export CGO_LDFLAGS="${LDFLAGS}"
- export GOFLAGS+="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
- make
+ local flags="-s -w -X main.version=${pkgver} -X main.date=$(date +%FT%T%z)"
- # Clean mod cache for makepkg -C
+ go build \
+ -trimpath \
+ -buildmode=pie \
+ -mod=readonly \
+ -modcacherw \
+ -ldflags "-linkmode external -extldflags \"${LDFLAGS}\" ${flags}" \
+ -o bin/"$pkgname"
+}
+
+check() {
+ cd "wtf-$pkgver"
+ go test ./...
+
+ # Clean mod cache for makepkg -C
go clean -modcache
}
package() {
cd "wtf-$pkgver"
install -Dm755 "bin/$pkgname" -t "$pkgdir/usr/bin"
- install -Dm644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname"
install -Dm644 {README,CHANGELOG}.md -t "$pkgdir/usr/share/doc/$pkgname"
cp -r _sample_configs "$pkgdir/usr/share/doc/$pkgname/sample_configs"
}