summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2021-01-18 12:19:22 -0700
committerMark Wagie2021-01-18 12:19:22 -0700
commitbe694963ec28abde311937b01433d56f6f6f82c3 (patch)
tree58710aa972015b1ac93f3f785763109de8f70e6e
parent39571a843f2f9cdc7999f4f96ff83255652b2c57 (diff)
downloadaur-be694963ec28abde311937b01433d56f6f6f82c3.tar.gz
0.35.0
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD38
3 files changed, 34 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 68fb51bef1e3..6230d1f0cff2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = wtfutil
pkgdesc = Personal information dashboard for your terminal
- pkgver = 0.30.0
+ pkgver = 0.35.0
pkgrel = 1
url = https://wtfutil.com
- arch = i686
arch = x86_64
arch = aarch64
arch = armv6h
license = MPL2
- makedepends = go-pie>=1.13
- source = wtfutil-0.30.0.tar.gz::https://github.com/wtfutil/wtf/archive/v0.30.0.tar.gz
- sha256sums = 71a017c1744f6d5d68eee2e4f9f0126f4da23b79eb1fea21ae8fd97c306f4b16
+ makedepends = go
+ source = wtfutil-0.35.0.tar.gz::https://github.com/wtfutil/wtf/archive/v0.35.0.tar.gz
+ sha256sums = 9fcf24d41ff9a96aa257d59322c1d4577ebf1101ccdfd792a0c5c4d93bb0c6d3
pkgname = wtfutil
diff --git a/.gitignore b/.gitignore
index f52b2f5a9940..4dab8d6386e3 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,7 @@
-pkg/
-src/
-*.tar.xz
-*.tar.gz
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 00ed0651cf9b..5cd97555e268 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,40 @@
-# Maintainer: Kaio "yaakushi" Augusto <kaioaugusto dot 8 at gmail dot com>
-# Contributor: yochananmarqos
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
+# Contributor: Kaio "yaakushi" Augusto <kaioaugusto dot 8 at gmail dot com>
# Contributor: matthias.lisin
# Contributor: Bruno Inec <bruno at inec dot fr>
pkgname=wtfutil
-pkgver=0.30.0
+pkgver=0.35.0
pkgrel=1
pkgdesc="Personal information dashboard for your terminal"
-arch=('i686' 'x86_64' 'aarch64' 'armv6h')
+arch=('x86_64' 'aarch64' 'armv6h')
url="https://wtfutil.com"
license=('MPL2')
-makedepends=('go-pie>=1.13')
+makedepends=('go')
source=("$pkgname-$pkgver.tar.gz::https://github.com/wtfutil/wtf/archive/v$pkgver.tar.gz")
-sha256sums=('71a017c1744f6d5d68eee2e4f9f0126f4da23b79eb1fea21ae8fd97c306f4b16')
+sha256sums=('9fcf24d41ff9a96aa257d59322c1d4577ebf1101ccdfd792a0c5c4d93bb0c6d3')
+
+prepare() {
+ export GOPATH="$srcdir/gopath"
+ go clean -modcache
+}
build() {
- export GOPROXY="https://gocenter.io"
+ cd "wtf-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS+="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ make
- cd wtf-$pkgver
- go build \
- -trimpath \
- -ldflags "-extldflags $LDFLAGS -X 'main.version=$pkgver' -X 'main.date=$(date)'" \
- -o $pkgname .
+ # Clean mod cache for makepkg -C
+ go clean -modcache
}
-package(){
- cd "wtf-$pkgver"
- install -Dm755 "$pkgname" -t "$pkgdir/usr/bin/"
+package() {
+ cd "wtf-$pkgver"
+ install -Dm755 "bin/$pkgname" -t "$pkgdir/usr/bin"
install -Dm644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname"
install -Dm644 {README,CHANGELOG}.md -t "$pkgdir/usr/share/doc/$pkgname"
cp -r _sample_configs "$pkgdir/usr/share/doc/$pkgname/sample_configs"