summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKaio Augusto2020-04-19 15:24:33 -0300
committerKaio Augusto2020-04-19 15:24:33 -0300
commitceb55d85c7dff59e89d4bfd7ac846253ef74b565 (patch)
tree326766c6007187847ac716399eab504333c422d2
parent4ff637c1931c3bb197a87864806ff71765126ff7 (diff)
downloadaur-ceb55d85c7dff59e89d4bfd7ac846253ef74b565.tar.gz
Bump version to 0.28.0. Properly copying documentation and licenses now (thanks @yochananmarqos). Overriding version and date variables on build now.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9578974b56c3..6b79af96799c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wtfutil
pkgdesc = Personal information dashboard for your terminal
- pkgver = 0.27.0
+ pkgver = 0.28.0
pkgrel = 1
url = https://wtfutil.com
arch = i686
@@ -9,8 +9,8 @@ pkgbase = wtfutil
arch = armv6h
license = MPL2
makedepends = go-pie>=1.13
- source = wtfutil-0.27.0.tar.gz::https://github.com/wtfutil/wtf/archive/v0.27.0.tar.gz
- sha256sums = e2406f5f1572d293170ff6f17a1a0799b1cd1ab80f548dbccc28e8e1b4a7b451
+ source = wtfutil-0.28.0.tar.gz::https://github.com/wtfutil/wtf/archive/v0.28.0.tar.gz
+ sha256sums = a46c1d5177772107970e4487aa2ed860a267fd251ffce13648aee92b9e6e2028
pkgname = wtfutil
diff --git a/PKGBUILD b/PKGBUILD
index b1453f523f08..ef6aba03b732 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# Contributor: Bruno Inec <bruno at inec dot fr>
pkgname=wtfutil
-pkgver=0.27.0
+pkgver=0.28.0
pkgrel=1
pkgdesc="Personal information dashboard for your terminal"
arch=('i686' 'x86_64' 'aarch64' 'armv6h')
@@ -12,7 +12,7 @@ url="https://wtfutil.com"
license=('MPL2')
makedepends=('go-pie>=1.13')
source=("$pkgname-$pkgver.tar.gz::https://github.com/wtfutil/wtf/archive/v$pkgver.tar.gz")
-sha256sums=('e2406f5f1572d293170ff6f17a1a0799b1cd1ab80f548dbccc28e8e1b4a7b451')
+sha256sums=('a46c1d5177772107970e4487aa2ed860a267fd251ffce13648aee92b9e6e2028')
build() {
export GOPROXY="https://gocenter.io"
@@ -20,11 +20,14 @@ build() {
cd wtf-$pkgver
go build \
-trimpath \
- -ldflags "-extldflags $LDFLAGS" \
+ -ldflags "-extldflags $LDFLAGS -X 'main.version=$pkgver' -X 'main.date=$(date)'" \
-o $pkgname .
}
package(){
- cd wtf-$pkgver
- install -Dm755 $pkgname "$pkgdir/usr/bin/$pkgname"
+ cd "wtf-$pkgver"
+ install -Dm755 "$pkgname" -t "$pkgdir/usr/bin/"
+ install -Dm644 LICENSE.md -t "$pkgdir/usr/share/licenses/$pkgname"
+ install -Dm644 {README,CHANGELOG}.md -t "$pkgdir/usr/share/doc/$pkgname"
+ cp -r _sample_configs "$pkgdir/usr/share/doc/$pkgname/sample_configs"
}