summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmirreza Firoozi2016-06-06 21:18:12 +0430
committerAmirreza Firoozi2016-06-06 21:18:12 +0430
commite5094c5cdf39b6133208736232b626846256662b (patch)
treebf055434a4c369cd1483146d0c771e2247c1745f
downloadaur-e5094c5cdf39b6133208736232b626846256662b.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD25
-rw-r--r--changelog2
-rw-r--r--wttr.install10
4 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..16fe1a10bfb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = wttr
+ pkgdesc = a simple script that helps you check weather condition using site : http://wttr.in
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://Github.com/AmirrezaFiroozi/wttr
+ install = wttr.install
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = curl
+ source = https://github.com/AmirrezaFiroozi/wttr/archive/v1.2.1.tar.gz
+ md5sums = SKIP
+
+pkgname = wttr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92a74026976d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Amirreza Firoozi <firoozi128.af@gmail.com>
+pkgname=wttr
+pkgver=1.2.1
+pkgrel=1
+epoch=
+pkgdesc="a simple script that helps you check weather condition using site : http://wttr.in "
+arch=('i686' 'x86_64')
+url="https://Github.com/AmirrezaFiroozi/wttr"
+license=('GPL3')
+depends=('curl')
+install=$pkgname.install
+md5sums=('SKIP')
+changelog=
+source=("https://github.com/AmirrezaFiroozi/wttr/archive/v1.2.1.tar.gz")
+noextract=()
+
+package() {
+mkdir -p $pkgname/usr/bin/
+mkdir -p $pkgname/usr/share/${pkgname}/
+cp -r "$srcdir"/${pkgname}-${pkgver}/* $srcdir/
+ cd "$srcdir"
+ install -Dm0755 "wttr_main" $pkgdir/usr/bin/wttr
+ install -Dm0755 "changelog" $pkgdir/usr/share/${pkgname}/changelog
+}
+
diff --git a/changelog b/changelog
new file mode 100644
index 000000000000..01e4cb5da4d5
--- /dev/null
+++ b/changelog
@@ -0,0 +1,2 @@
+<1.2.1>
+Some bugs has fixed
diff --git a/wttr.install b/wttr.install
new file mode 100644
index 000000000000..4dd9080e58fa
--- /dev/null
+++ b/wttr.install
@@ -0,0 +1,10 @@
+post_install(){
+echo "Installation has just completed"
+echo "you can run : wttr -h if you need help (i will do it for you now :D)"
+wttr -h
+}
+post_remove(){
+echo "wttr has just removed from your computer"
+echo "You need to Manually remove .wttr directory from your home directory"
+echo "if there is any bug please let us know . firoozi128.af@gmail.com"
+}