summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122023-10-15 21:33:38 +0200
committerwillemw122023-10-15 21:33:38 +0200
commit61f1195f5dd1dfc81a121e3fdbfc3129ebdc7077 (patch)
treeb2c433b94a992263cadcc31b8f631d4a1f7c64fc
parent2463617f5488d73d93ef0cf618eabb977c9553a4 (diff)
downloadaur-61f1195f5dd1dfc81a121e3fdbfc3129ebdc7077.tar.gz
Use Rust's stable toolchain in prepare()
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a2d65f2dd14..f4d4edd2cf56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wttrbar-git
pkgdesc = Show the weather in Waybar, using the great wttr.io
pkgver = 0.4.0.r0.gdfa1473
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bjesus/wttrbar
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index 182f826bbb88..d8b75556f021 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wttrbar-git
pkgver=0.4.0.r0.gdfa1473
-pkgrel=1
+pkgrel=2
pkgdesc='Show the weather in Waybar, using the great wttr.io'
arch=(x86_64)
url=https://github.com/bjesus/wttrbar
@@ -20,7 +20,7 @@ pkgver() {
}
prepare() {
- cargo fetch --locked --manifest-path=$pkgname/Cargo.toml --target="$CARCH-unknown-linux-gnu"
+ RUSTUP_TOOLCHAIN=stable cargo fetch --locked --manifest-path=$pkgname/Cargo.toml --target="$CARCH-unknown-linux-gnu"
}
build() {
@@ -32,5 +32,5 @@ check() {
}
package() {
- install -Dm0755 "target/release/${pkgname%-git}" -t "$pkgdir/usr/bin"
+ install -Dm755 "target/release/${pkgname%-git}" -t "$pkgdir/usr/bin"
}