summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBen2022-03-29 16:37:05 +0800
committerBen2022-03-29 16:37:05 +0800
commit667e920ee97e15a846f0ca79a895ecf5a7364f09 (patch)
tree333ebc482e8458ffd7eaf0465ed52dda4658f791
parent9519d2cf7a9ff335a53b246d30000ced032c912c (diff)
downloadaur-wudao-dict-git.tar.gz
Use project name in source. Update md5sum of wd
* Use project name in source, rather then _pkgname * update md5sum of wd
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04fe9db2bd6b..47a8fbab6077 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wudao-dict-git
pkgdesc = The command line version of Youdao Dictionary, supporting English-Chinese mutual search and online search.
pkgver = r18.caceb83
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ChestnutHeng/Wudao-dict
install = wudao-dict-git.install
arch = any
@@ -10,9 +10,9 @@ pkgbase = wudao-dict-git
depends = python
depends = python-bs4
depends = python-lxml
- source = git+https://github.com/ChestnutHeng/Wudao-dict.git
+ source = wudao-dict-git::git+https://github.com/ChestnutHeng/Wudao-dict
source = wd
md5sums = SKIP
- md5sums = 7e504991b277c83136466f885626cd7c
+ md5sums = 4e61df0c22c14fc8a7a8950a9c42d9d2
pkgname = wudao-dict-git
diff --git a/PKGBUILD b/PKGBUILD
index fcae1df1feff..a4afb32d22d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,7 @@
# Maintainer: Ben <bensongsyz@gmail.com>
pkgname='wudao-dict-git'
-_pkgname='Wudao-dict'
pkgver=r18.caceb83
-pkgrel=1
+pkgrel=2
pkgdesc='The command line version of Youdao Dictionary, supporting English-Chinese mutual search and online search.'
arch=('any')
url="https://github.com/ChestnutHeng/Wudao-dict"
@@ -10,18 +9,18 @@ license=('unknown')
depends=('python' 'python-bs4' 'python-lxml')
install="wudao-dict-git.install"
makedepends=('git')
-source=('git+https://github.com/ChestnutHeng/Wudao-dict.git'
+source=("$pkgname::git+https://github.com/ChestnutHeng/Wudao-dict"
'wd')
md5sums=('SKIP'
- '7e504991b277c83136466f885626cd7c')
+ '4e61df0c22c14fc8a7a8950a9c42d9d2')
pkgver() {
- cd "$_pkgname"
+ cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
mkdir -p "${pkgdir}/opt"
- cp -r "./Wudao-dict/wudao-dict" "${pkgdir}/opt/"
+ cp -r "./$pkgname/wudao-dict" "${pkgdir}/opt/"
# 添加系统命令wd
mkdir -p "${pkgdir}/usr/bin"