summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn-Gee2019-07-19 03:54:06 -0700
committerJohn-Gee2019-07-19 03:54:06 -0700
commit21370cf20388984635ebd7cb1c4a5739d891447b (patch)
tree61cdd6d5fe23b03b14970987a9950ec2bbffd234
downloadaur-21370cf20388984635ebd7cb1c4a5739d891447b.tar.gz
Initial
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 31 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82c055402279
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = wudcompress
+ pkgdesc = Wii U image (WUD) compression tool
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://gbatemp.net/threads/wii-u-image-wud-compression-tool.397901/
+ arch = x86_64
+ source = https://github.com/John-Gee/wudcompress/archive/master.zip
+ sha256sums = dff8834b21309e09567834e9024f609dbb74bebb83d4cca7bbe4701cf443b163
+
+pkgname = wudcompress
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f70d3121aa43
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: gee
+
+pkgname=wudcompress
+pkgver=1.0
+pkgrel=1
+pkgdesc='Wii U image (WUD) compression tool'
+arch=('x86_64')
+url='https://gbatemp.net/threads/wii-u-image-wud-compression-tool.397901/'
+source=("https://github.com/John-Gee/wudcompress/archive/master.zip")
+sha256sums=('dff8834b21309e09567834e9024f609dbb74bebb83d4cca7bbe4701cf443b163')
+
+build() {
+ cd ${srcdir}/wudcompress-master
+
+ gcc main.cpp wud.cpp -o wudcompress -Wno-multichar
+}
+
+package() {
+ install -Dm 755 ${srcdir}/wudcompress-master/wudcompress -t "${pkgdir}"/usr/bin/
+}