summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAbheek Dhawan2022-04-23 15:33:00 -0500
committerAbheek Dhawan2022-04-23 15:33:00 -0500
commit09705f9e9347a84417f74d85da370f7ae6c8f08b (patch)
treed78645b45d494e0813102ce1e23c092048450167
downloadaur-09705f9e9347a84417f74d85da370f7ae6c8f08b.tar.gz
Initial package addition
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e0f9d0c6ed9e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = wwise-audio-tools-git
+ pkgdesc = Tools for working with Wwise file types (only extraction at the moment)
+ pkgver = 0.5.0
+ pkgrel = 1
+ arch = x86_64
+ license = MIT
+ makedepends = cmake
+ makedepends = ninja
+ makedepends = git
+ source = git+https://github.com/WolvenKit/wwise-audio-tools
+ sha512sums = SKIP
+
+pkgname = wwise-audio-tools-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f8ae56b0371
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Abheek Dhawan <abheekd at protonmail dot com>
+
+pkgname="wwise-audio-tools-git"
+pkgver="0.5.0"
+pkgrel=1
+pkgdesc="Tools for working with Wwise file types (only extraction at the moment)"
+arch=("x86_64")
+license=("MIT")
+makedepends=("cmake" "ninja" "git")
+source=("git+https://github.com/WolvenKit/wwise-audio-tools")
+sha512sums=("SKIP")
+
+prepare() {
+ cd "${srcdir}/wwise-audio-tools"
+ git submodule update --init
+}
+
+build() {
+ cmake -G "Ninja" -B build -S "${srcdir}/wwise-audio-tools" \
+ -DCMAKE_INSTALL_PREFIX="/usr" \
+ -Wno-dev
+ cmake --build build
+}
+
+package() {
+ DESTDIR="$pkgdir" PREFIX="usr" cmake --install build
+}