summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAbheek Dhawan2022-04-23 19:41:31 -0500
committerAbheek Dhawan2022-04-23 19:41:31 -0500
commit27b8bcd85879f4c52d054fc50794c77bd122db53 (patch)
treee174309339179398733b06df2905db82a9d934ab
parent64947bf48ed31a0b09d2f6000b10023dc04b2772 (diff)
downloadaur-27b8bcd85879f4c52d054fc50794c77bd122db53.tar.gz
Add better support for versioning
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd4f8468fe58..fb3ee0de09e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wwise-audio-tools-git
pkgdesc = Tools for working with Wwise file types (only extraction at the moment)
- pkgver = 0.5.0
+ pkgver = 0.5.0.r3.g16400e4
pkgrel = 1
url = https://github.com/WolvenKit/wwise-audio-tools
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 1f05ef85e953..3abfe7f65321 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Abheek Dhawan <abheekd at protonmail dot com>
pkgname="wwise-audio-tools-git"
-pkgver="0.5.0"
+pkgver=0.5.0.r3.g16400e4
pkgrel=1
pkgdesc="Tools for working with Wwise file types (only extraction at the moment)"
arch=("x86_64")
@@ -11,6 +11,11 @@ makedepends=("cmake" "ninja" "git")
source=("git+https://github.com/WolvenKit/wwise-audio-tools")
sha512sums=("SKIP")
+pkgver() {
+ cd ${srcdir}/wwise-audio-tools
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
prepare() {
cd "${srcdir}/wwise-audio-tools"
git submodule update --init