summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorroot2021-05-09 21:54:39 +0200
committerroot2021-05-09 21:54:39 +0200
commitb54ff3fbdf3ab4732f49ce4de9f11a2ce1b10e32 (patch)
treee14daff98195f6c713c981e4b79c6158a023ef53
parent2f028b4308fd54cc38921845545708271646048d (diff)
downloadaur-b54ff3fbdf3ab4732f49ce4de9f11a2ce1b10e32.tar.gz
New upstream commit; patch to fix wwwoffled's help output for debug levels no longer needed.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD16
2 files changed, 12 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bb739506596d..8861695d490c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wwwoffle-svn
pkgdesc = Simple caching proxy server with special features (request, recursive fetch, subscription, modify HTML, ...) for use with dial-up internet links. Includes startup scripts for OpenRC, System V init, systemd.
- pkgver = 2.9j+svn2253.d20191028
- pkgrel = 5
+ pkgver = 2.9j+svn2254.d20210509
+ pkgrel = 1
epoch = 1
url = http://www.gedanken.org.uk/software/wwwoffle/
install = wwwoffle.install
@@ -11,6 +11,7 @@ pkgbase = wwwoffle-svn
arch = x86_64
license = GPL2
makedepends = subversion
+ makedepends = ccache
depends = gnutls
depends = libgcrypt
depends = zlib
@@ -19,15 +20,15 @@ pkgbase = wwwoffle-svn
optdepends = sysvinit: For system-V-style initscript.
optdepends = perl: For 'scripts/README.CONF-html.pl' script which creates an HTML version of 'README.CONF'.
optdepends = ruby: For 'contrib/eregister/eregister' tool which indexes the cache.
- provides = wwwoffle=2.9j+svn2253.d20191028
- provides = wwwoffle-sysvinit=2.9j+svn2253.d20191028
- provides = wwwoffle-openrc=2.9j+svn2253.d20191028
- provides = wwwoffle-systemd=2.9j+svn2253.d20191028
+ provides = wwwoffle=2.9j+svn2254.d20210509
+ provides = wwwoffle-sysvinit=2.9j+svn2254.d20210509
+ provides = wwwoffle-openrc=2.9j+svn2254.d20210509
+ provides = wwwoffle-systemd=2.9j+svn2254.d20210509
conflicts = wwwoffle
conflicts = wwwoffle-sysvinit
conflicts = wwwoffle-openrc
conflicts = wwwoffle-systemd
- replaces = wwwoffle<=2.9j+svn2253.d20191028
+ replaces = wwwoffle<=2.9j+svn2254.d20210509
options = emptydirs
backup = etc/conf.d/wwwoffle
backup = etc/wwwoffle/wwwoffle.conf
@@ -37,14 +38,12 @@ pkgbase = wwwoffle-svn
source = initscript_systemd
source = initscript_sysvinit
source = wwwoffle.install
- source = fix-wwwoffled-loglevel-help.patch::http://ix.io/3lYX
sha256sums = SKIP
sha256sums = 5491ffc23ae113db4b46167883594b5bcb6f1bbd0ce11432bc45047efbd635d2
sha256sums = d9451db92f979a6573cecbab23c26b6ca8ea026ef61b22ec4b61c0c9051142e9
sha256sums = 03bebce87a0da1b383666ab7a95b9810e15f2a024c0954f09c959d342c5d9c87
sha256sums = 62139f2b77139cf9c1ce9761e27f6b427c12cadd7a3739f28d854b8328e7c511
sha256sums = 106f4ce3de6d6ea020e8dcd8a4fd4f78ed2ae855e8a953a8783134e4d2cfba12
- sha256sums = 85f0b786356c0f35b3dedf074757dec1d05256e93aa822b08cdb8530c3dbd072
pkgname = wwwoffle-svn
diff --git a/PKGBUILD b/PKGBUILD
index 18a8083fd77c..177ea727cff8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
# Contributor: Vasco Costa <vasco dot costa at geekslot dot com>
# Contributor: jaro3
-_USE_CCACHE=false
-# _USE_CCACHE=true
+# _USE_CCACHE=false
+_USE_CCACHE=true
_pkgname=wwwoffle
pkgname="${_pkgname}-svn"
epoch=1
# _pkgver=2.9j
-pkgver=2.9j+svn2253.d20191028
-pkgrel=5
+pkgver=2.9j+svn2254.d20210509
+pkgrel=1
pkgdesc="Simple caching proxy server with special features (request, recursive fetch, subscription, modify HTML, ...) for use with dial-up internet links. Includes startup scripts for OpenRC, System V init, systemd."
arch=(
'arm'
@@ -77,7 +77,6 @@ source=(
'initscript_systemd'
'initscript_sysvinit'
"${install}"
- 'fix-wwwoffled-loglevel-help.patch::http://ix.io/3lYX'
)
sha256sums=(
@@ -88,7 +87,6 @@ sha256sums=(
'03bebce87a0da1b383666ab7a95b9810e15f2a024c0954f09c959d342c5d9c87' # initscript_systemd
'62139f2b77139cf9c1ce9761e27f6b427c12cadd7a3739f28d854b8328e7c511' # initscript_sysvinit
'106f4ce3de6d6ea020e8dcd8a4fd4f78ed2ae855e8a953a8783134e4d2cfba12' # ${install}
- '85f0b786356c0f35b3dedf074757dec1d05256e93aa822b08cdb8530c3dbd072' # fix-wwwoffled-loglevel-help.patch
)
_svnlog='svn.log'
@@ -153,12 +151,6 @@ prepare() {
cd "${_unpackeddir}"
- ### Applying patches
- for _patch in 'fix-wwwoffled-loglevel-help.patch'; do
- msg2 "Applying patch '${_patch}' ..."
- patch -N -p1 -i "${srcdir}/fix-wwwoffled-loglevel-help.patch"
- done
-
### Update version.h to the actual version + SVNrevision
msg2 "Updating version in src/version.h to ${pkgver} ..."
sed -i 's|^\([[:space:]]*#define[[:space:]]*WWWOFFLE_VERSION[[:space:]]*\).*$|/*+ +*/\n/*+ The following line was automatically upgraded by the Arch Linux PKGBUILD (package build script) +*/\n/*+ in order to match the version as in conf/wwwoffle.conf.template and the SVN revision. +*/\n\1"'"${pkgver}"'"|' \