summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordvx2021-08-24 21:36:45 +0200
committerdvx2021-08-24 21:36:45 +0200
commit4b89552b0bf2a3e1765ee27fa8de6004f801ecf5 (patch)
tree1300c0ee773d8a9a05b50d7950acb5937803c720
downloadaur-4b89552b0bf2a3e1765ee27fa8de6004f801ecf5.tar.gz
New release 0.70.1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
-rw-r--r--wxdfast.install11
3 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c7763eca8d11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wxdfast
+ pkgdesc = Multithread download manager
+ pkgver = 0.70.1
+ pkgrel = 1
+ url = https://wxdfast.dxsolutions.org
+ install = wxdfast.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = wxgtk3
+ depends = aria2
+ depends = openssl
+ source = https://github.com/archdvx/wxdfast/releases/download/v0.70.1/wxdfast-0.70.1.tar.gz
+ md5sums = 54ca34fdc3fd71723dbca412a38a9df1
+
+pkgname = wxdfast
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc7e5a13c708
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: David Vachulka <archdvx@dxsolutions.org>
+
+pkgname=wxdfast
+pkgver=0.70.1
+pkgrel=1
+pkgdesc="Multithread download manager"
+arch=('i686' 'x86_64')
+url="https://wxdfast.dxsolutions.org"
+license=('GPL')
+depends=('wxgtk3' 'aria2' 'openssl')
+makedepends=('cmake')
+install=${pkgname}.install
+source=(https://github.com/archdvx/wxdfast/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz)
+md5sums=('54ca34fdc3fd71723dbca412a38a9df1')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DDX_WX_CONFIG=wx-config-gtk3
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+}
diff --git a/wxdfast.install b/wxdfast.install
new file mode 100644
index 000000000000..21b79d2d44de
--- /dev/null
+++ b/wxdfast.install
@@ -0,0 +1,11 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}