summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQirui Wang2019-05-03 02:33:36 -0400
committerQirui Wang2019-05-03 02:33:36 -0400
commit9a281ba5476d036146b1d878fcbe7e5c9ffaa236 (patch)
tree6310b4bae9c57eea8e411893867a0cfe1825d967
parentc4559192f11bb894f27d15ef4fdc318e613d0b27 (diff)
downloadaur-9a281ba5476d036146b1d878fcbe7e5c9ffaa236.tar.gz
v3.1.2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
-rw-r--r--make-abicheck-non-fatal.patch15
3 files changed, 11 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dcf3247321a2..035da331d59a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = wxgtk-dev
- pkgver = 3.1.1
+ pkgver = 3.1.2
pkgrel = 1
url = https://wxwidgets.org
arch = x86_64
@@ -11,16 +11,9 @@ pkgbase = wxgtk-dev
makedepends = libnotify
makedepends = gtk2
options = !emptydirs
- source = https://github.com/wxWidgets/wxWidgets/releases/download/v3.1.1/wxWidgets-3.1.1.tar.bz2
- source = make-abicheck-non-fatal.patch
- source = wxgtk-webkit2gtk.patch::https://github.com/wxWidgets/wxWidgets/commit/ec6e54bc.patch
- source = wxgtk2-fix-webview.patch::https://github.com/wxWidgets/wxWidgets/commit/fd247cca.patch
- source = wxgtk-filezilla-assert.patch::https://github.com/wxWidgets/wxWidgets/commit/ce1dce11.patch
- sha1sums = f999c3cf1887c0a60e519214c14b15cb9bb5ea6e
- sha1sums = dfe38650c655395b90bf082b5734c4093508bfa3
- sha1sums = d2bd62d0852f3647782780565849692e7837c10c
- sha1sums = 550c368a68eec8b6c32c61da289df76e4dd5a798
- sha1sums = 1da8af91ef6c590da9c43dd115f52d605730f16a
+ source = https://github.com/wxWidgets/wxWidgets/releases/download/v3.1.2/wxWidgets-3.1.2.tar.bz2
+ sha1sums = 29cbbba946d2a7b4d28ca1db12315810cc8de74d
+ sha256sums = 4cb8d23d70f9261debf7d6cfeca667fc0a7d2b6565adb8f1c484f9b674f1f27a
pkgname = wxgtk2-dev
pkgdesc = GTK+2 implementation of wxWidgets API for GUI
diff --git a/PKGBUILD b/PKGBUILD
index 69b0f5082f8c..f808f738cdf3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,20 @@
+# Maintainer: Qirui Wang <wqr.prg@gmail.com>
+
pkgbase=wxgtk-dev
pkgname=(wxgtk2-dev wxgtk3-dev wxgtk-common-dev)
-pkgver=3.1.1
+pkgver=3.1.2
pkgrel=1
arch=('x86_64')
url="https://wxwidgets.org"
license=('custom:wxWindows')
makedepends=('gst-plugins-base' 'gconf' 'glu' 'webkit2gtk' 'libnotify' 'gtk2')
options=('!emptydirs')
-source=(https://github.com/wxWidgets/wxWidgets/releases/download/v$pkgver/wxWidgets-$pkgver.tar.bz2
- make-abicheck-non-fatal.patch wxgtk-webkit2gtk.patch::"https://github.com/wxWidgets/wxWidgets/commit/ec6e54bc.patch"
- wxgtk2-fix-webview.patch::"https://github.com/wxWidgets/wxWidgets/commit/fd247cca.patch"
- wxgtk-filezilla-assert.patch::"https://github.com/wxWidgets/wxWidgets/commit/ce1dce11.patch")
-sha1sums=('f999c3cf1887c0a60e519214c14b15cb9bb5ea6e'
- 'dfe38650c655395b90bf082b5734c4093508bfa3'
- 'd2bd62d0852f3647782780565849692e7837c10c'
- '550c368a68eec8b6c32c61da289df76e4dd5a798'
- '1da8af91ef6c590da9c43dd115f52d605730f16a')
+source=("https://github.com/wxWidgets/wxWidgets/releases/download/v$pkgver/wxWidgets-$pkgver.tar.bz2")
+sha1sums=('29cbbba946d2a7b4d28ca1db12315810cc8de74d')
+sha256sums=('4cb8d23d70f9261debf7d6cfeca667fc0a7d2b6565adb8f1c484f9b674f1f27a')
prepare() {
- cd wxWidgets-${pkgver}
-
- # C++ ABI check is too strict and breaks with GCC 5.1
- # https://bugzilla.redhat.com/show_bug.cgi?id=1200611
- #patch -Np1 -i ../make-abicheck-non-fatal.patch
-
- # Support webkit2gtk
- #sed -e 's|setup0.h|setup.h|g' -i ../wxgtk-webkit2gtk.patch
- #patch -p1 -i ../wxgtk-webkit2gtk.patch
- # fix webview after webkit2gtk port
- #patch -p1 -i ../wxgtk2-fix-webview.patch
- # fix assert in FileZilla
- #patch -p1 -i ../wxgtk-filezilla-assert.patch
-
- cd ..
- cp -r wxWidgets-${pkgver} wxWidgets-${pkgver}-gtk3
+ cp -a wxWidgets-${pkgver} wxWidgets-${pkgver}-gtk3
}
build() {
diff --git a/make-abicheck-non-fatal.patch b/make-abicheck-non-fatal.patch
deleted file mode 100644
index 97055ba46fad..000000000000
--- a/make-abicheck-non-fatal.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -up wxGTK-2.8.12/src/common/appbase.cpp.abicheck wxGTK-2.8.12/src/common/appbase.cpp
---- wxGTK-2.8.12/src/common/appbase.cpp.abicheck 2015-03-12 17:15:18.000000000 +0100
-+++ wxGTK-2.8.12/src/common/appbase.cpp 2015-03-12 17:15:57.000000000 +0100
-@@ -424,10 +424,7 @@ bool wxAppConsole::CheckBuildOptions(con
- msg.Printf(_T("Mismatch between the program and library build versions detected.\nThe library used %s,\nand %s used %s."),
- lib.c_str(), progName.c_str(), prog.c_str());
-
-- wxLogFatalError(msg.c_str());
--
-- // normally wxLogFatalError doesn't return
-- return false;
-+ wxLogWarning(msg.c_str());
- }
- #undef wxCMP
-