summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaksim Fomin2019-09-07 20:31:19 +0000
committerMaksim Fomin2019-09-07 20:31:19 +0000
commitc385f31e877adb42ef1754fa04113df07b11f545 (patch)
treed1110667aafff178d08fe0631bf1d161d248c3a9
parented139fbfbc36275f2b2c7d8c81fe30c6d939cb15 (diff)
downloadaur-c385f31e877adb42ef1754fa04113df07b11f545.tar.gz
Add patch to remove strange console output
-rw-r--r--.SRCINFO4
-rw-r--r--02-remove-strange-output.patch14
-rw-r--r--PKGBUILD9
3 files changed, 23 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7788819ec8b9..17a49981b5d3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wxhexeditor
pkgdesc = A free hex editor / disk editor for Linux, Windows and MacOSX
pkgver = 0.24
- pkgrel = 3
+ pkgrel = 4
url = http://www.wxhexeditor.org
arch = i686
arch = x86_64
@@ -12,8 +12,10 @@ pkgbase = wxhexeditor
optdepends = polkit: For root access support
source = https://github.com/EUA/wxHexEditor/archive/v0.24.tar.gz
source = 01-add-pkexec-support.patch
+ source = 02-remove-strange-output.patch
md5sums = 1b77bddc026e22797fd0e7a82e52cd28
md5sums = e62ae9e6b0aac2afdcc41b51cab39272
+ md5sums = 9f8f2ea86c7cc1d4706ac8c4862cfb51
pkgname = wxhexeditor
diff --git a/02-remove-strange-output.patch b/02-remove-strange-output.patch
new file mode 100644
index 000000000000..d9a20103c6bd
--- /dev/null
+++ b/02-remove-strange-output.patch
@@ -0,0 +1,14 @@
+diff --git a/src/HexEditor.cpp b/src/HexEditor.cpp
+index 8a69ba7..ca15563 100644
+--- a/src/HexEditor.cpp
++++ b/src/HexEditor.cpp
+@@ -42,9 +42,6 @@ HexEditor::HexEditor( wxWindow* parent,
+ tagpanel(tagpanel_),
+ dasmpanel(dasmpanel_) {
+ ComparatorHexEditor=NULL;
+- // Here, code praying to the GOD for protecting our open file from wxHexEditor's bugs and other things.
+- // This is really crucial step! Be adviced to not remove it, even if you don't believer.
+- printf("Rahman ve Rahim olan Allah'ın adıyla.\n");
+ myfile = NULL;
+ #ifndef DO_NOT_USE_THREAD_FOR_SCROLL
+ myscrollthread = NULL;
diff --git a/PKGBUILD b/PKGBUILD
index 9981885cefca..3947564f069f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wxhexeditor
pkgver=0.24
-pkgrel=3
+pkgrel=4
pkgdesc="A free hex editor / disk editor for Linux, Windows and MacOSX"
arch=('i686' 'x86_64')
url="http://www.wxhexeditor.org"
@@ -13,13 +13,16 @@ makedepends=('python')
optdepends=('gksu: For root access support'
'polkit: For root access support')
source=("https://github.com/EUA/wxHexEditor/archive/v$pkgver.tar.gz"
- "01-add-pkexec-support.patch")
+ "01-add-pkexec-support.patch"
+ "02-remove-strange-output.patch")
md5sums=('1b77bddc026e22797fd0e7a82e52cd28'
- 'e62ae9e6b0aac2afdcc41b51cab39272')
+ 'e62ae9e6b0aac2afdcc41b51cab39272'
+ '9f8f2ea86c7cc1d4706ac8c4862cfb51')
prepare() {
cd "$srcdir/wxHexEditor-$pkgver"
patch -Np1 -i "${srcdir}/01-add-pkexec-support.patch"
+ patch -Np1 -i "${srcdir}/02-remove-strange-output.patch"
}
build() {