summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-11 12:05:04 +0300
committerCaleb Maclennan2020-02-11 12:20:44 +0300
commit9409b65f9469f6612e19beaf5c4c0c3909a39fe9 (patch)
treeb47c018d10fdf16b1cc573f8146524b4ea026b1e
parent11af6c0c6da72430ee52eaff69090ed20f10ee56 (diff)
downloadaur-9409b65f9469f6612e19beaf5c4c0c3909a39fe9.tar.gz
Update to 3.0.0.8
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD70
2 files changed, 35 insertions, 54 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a63a84ad2a0..5b59425644ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,18 @@
pkgbase = wxlua
- pkgdesc = A set of bindings to the wxWidgets library for the Lua programming language.
- pkgver = 2.8.12.3
- pkgrel = 4
- url = http://wxlua.sourceforge.net
+ pkgdesc = Lua bindings fore the wxWidgets library (Lua 5.3 compatible fork)
+ pkgver = 3.0.0.8
+ pkgrel = 1
+ url = https://github.com/pkulchenko/wxlua
arch = i686
arch = x86_64
license = custom:wxWindows
makedepends = cmake
- depends = lua52
depends = desktop-file-utils
- depends = wxgtk2.8
- depends = webkitgtk2
+ depends = wxgtk2
+ depends = lua
optdepends = webkit2gtk
- provides = wxstedit
- conflicts = wxstedit
- source = http://downloads.sourceforge.net/wxlua/wxlua/2.8.12.3/wxLua-2.8.12.3-src.tar.gz
- md5sums = e0a28904d046400713c07d7c4c9515ef
+ source = wxlua-3.0.0.8.tar.gz::https://github.com/pkulchenko/wxlua/archive/v3.0.0.8.tar.gz
+ sha256sums = 85d5182eec6e7cbb8428b9c144ef7fbe364f4fed6411aafcead648893e5b6fa0
pkgname = wxlua
diff --git a/PKGBUILD b/PKGBUILD
index a2d034b40227..7f76a38fb9df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,60 +5,44 @@
# Contributor: favardin
pkgname=wxlua
-pkgver=2.8.12.3
-pkgrel=4
-pkgdesc="A set of bindings to the wxWidgets library for the Lua programming language."
+pkgver=3.0.0.8
+pkgrel=1
+pkgdesc="Lua bindings fore the wxWidgets library (Lua 5.3 compatible fork)"
arch=('i686' 'x86_64')
-url="http://wxlua.sourceforge.net"
+url="https://github.com/pkulchenko/${pkgname}"
license=('custom:wxWindows')
-depends=('lua52' 'desktop-file-utils' 'wxgtk2.8' 'webkitgtk2')
+depends=('desktop-file-utils' 'wxgtk2' 'lua')
optdepends=('webkit2gtk')
makedepends=('cmake')
-provides=('wxstedit')
-conflicts=('wxstedit')
-source=("http://downloads.sourceforge.net/$pkgname/$pkgname/$pkgver/wxLua-$pkgver-src.tar.gz")
-md5sums=('e0a28904d046400713c07d7c4c9515ef')
-
-prepare() {
- cd wxLua-"$pkgver"-src
- [ -d b ] || mkdir b
-
- # wxstedit doc folder fix
- sed -i 's|doc/|share/&|' modules/wxstedit/CMakeLists.txt
-
- # right shebang for wxluafreeze.lua
- sed -i 's| \..*/|/usr/bin/env |;1s||$|' apps/wxluafreeze/wxluafreeze.lua
-}
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/pkulchenko/${pkgname}/archive/v${pkgver}.tar.gz")
+sha256sums=('85d5182eec6e7cbb8428b9c144ef7fbe364f4fed6411aafcead648893e5b6fa0')
build() {
- cd wxLua-"$pkgver"-src/b
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_BUILD_TYPE=Release \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config-2.8 \
- -DwxLua_LUA_INCLUDE_DIR=/usr/include \
- -DwxLua_LUA_LIBRARY=/usr/lib/liblua.so.5.2 \
- -DwxLua_LUA_LIBRARY_USE_BUILTIN=0 \
- -DwxLua_LUA_LIBRARY_VERSION=5.2
- make
+ cd "${pkgname}-${pkgver}/wxLua/build"
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DwxWidgets_COMPONENTS="stc;gl;html;aui;adv;core;net;base" \
+ -DwxLuaBind_COMPONENTS="stc;gl;html;aui;adv;core;net;base" \
+ -DBUILD_SHARED_LIBS=TRUE
+ make
}
package() {
- cd wxLua-"$pkgver"-src/b
- make DESTDIR="$pkgdir/" install
+ cd "${pkgname}-${pkgver}/wxLua/build"
+ make DESTDIR="$pkgdir/" install
+ rm "$pkgdir"/usr/bin/lua{,c}
+
+ install -d "$pkgdir/usr/lib/lua/5.3"
+ mv "$pkgdir/usr/lib/libwx.so" "$pkgdir/usr/lib/lua/5.3/wx.so"
- # mv lua module
- install -d "$pkgdir/usr/lib/lua/5.2"
- mv "$pkgdir/usr/lib/libwx.so" "$pkgdir/usr/lib/lua/5.2/wx.so"
+ pushd ..
- # desktop file
- install -Dm644 ../distrib/autopackage/"$pkgname".desktop \
- "$pkgdir/usr/share/applications/$pkgname.desktop"
+ install -Dm644 distrib/autopackage/"$pkgname".desktop \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
- # mime file
- install -Dm644 ../distrib/autopackage/"$pkgname".xml \
- "$pkgdir/usr/share/mime/packages/$pkgname.xml"
+ install -Dm644 distrib/autopackage/"$pkgname".xml \
+ "$pkgdir/usr/share/mime/packages/$pkgname.xml"
- # license
- install -Dm 644 ../docs/licence.txt \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 644 docs/licence.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}