summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-12 13:36:51 +0300
committerCaleb Maclennan2020-02-12 13:36:51 +0300
commitacc1aff56c00bb3870f1d984e8cbde5723c7bcfc (patch)
treecea63cb71bcc33b6d2ed1434b7207f2a863cd757
parent6688f94a981a3240ace62fe03ae18795f48d3948 (diff)
downloadaur-acc1aff56c00bb3870f1d984e8cbde5723c7bcfc.tar.gz
Cleanup bash shell quoting using shellharden
-rw-r--r--PKGBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e6c87a7eb692..46242c89958c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,17 +9,17 @@ pkgver=3.0.0.8
pkgrel=2
pkgdesc="Lua bindings for wxWidgets (Lua 5.3 compatible fork)"
arch=('i686' 'x86_64')
-url="https://github.com/pkulchenko/${pkgname}"
+url="https://github.com/pkulchenko/$pkgname"
license=('custom:wxWindows')
depends=('desktop-file-utils' 'wxgtk2' 'lua')
optdepends=('webkit2gtk')
makedepends=('cmake')
checkdepends=('cppcheck')
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/pkulchenko/${pkgname}/archive/v${pkgver}.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::https://github.com/pkulchenko/$pkgname/archive/v$pkgver.tar.gz")
sha256sums=('85d5182eec6e7cbb8428b9c144ef7fbe364f4fed6411aafcead648893e5b6fa0')
build() {
- cd "${pkgname}-${pkgver}/wxLua/build"
+ cd "$pkgname-$pkgver/wxLua/build"
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DwxLua_LUA_LIBRARY_USE_BUILTIN=FALSE \
-DwxLua_LUA_LIBRARY_BUILD_SHARED=TRUE \
@@ -33,7 +33,7 @@ build() {
}
package() {
- cd "${pkgname}-${pkgver}/wxLua"
+ cd "$pkgname-$pkgver/wxLua"
pushd "build"
make DESTDIR="$pkgdir/" install
rm -f "$pkgdir"/usr/bin/lua{,c}
@@ -45,6 +45,6 @@ package() {
install -Dm 644 docs/licence.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
pushd distrib/autopackage
- install -Dm644 "${pkgname}.desktop" -t "${pkgdir}/usr/share/applications/"
- install -Dm644 "${pkgname}.xml" -t "${pkgdir}/usr/share/mime/packages/"
+ install -Dm644 "$pkgname.desktop" -t "$pkgdir/usr/share/applications/"
+ install -Dm644 "$pkgname.xml" -t "$pkgdir/usr/share/mime/packages/"
}