summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2024-04-02 13:27:46 +0300
committerCaleb Maclennan2024-04-02 13:27:46 +0300
commit85fef3310dd0c8bd3ea92aa5df45332881dd057a (patch)
tree6b79a3adb3022792dfcce8755c8e67ee5b0da6e7
parent0d5feabb90a1bad113a46d132bc23395a3fcbf28 (diff)
downloadaur-wxlua-git.tar.gz
upgpkg: wxlua-git 1:3.2.0.2.r13.g4d83c8d-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD77
2 files changed, 46 insertions, 47 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1da5c483f9df..d958c6f01a91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,22 @@
pkgbase = wxlua-git
- pkgdesc = Lua bindings for wxWidgets (Lua 5.3 compatible fork)
- pkgver = 3.0.0.8.r22.gdfd9963
+ pkgdesc = Lua bindings for wxWidgets (Lua 5.3+ compatible fork)
+ pkgver = 3.2.0.2.r13.g4d83c8d
pkgrel = 1
epoch = 1
url = https://github.com/pkulchenko/wxlua
arch = i686
arch = x86_64
- license = custom:wxWindows
+ license = wxWindows
checkdepends = cppcheck
- makedepends = git
makedepends = cmake
+ makedepends = git
depends = desktop-file-utils
- depends = wxgtk2
depends = lua
- provides = wxlua
+ depends = wxwidgets-gtk3
+ optdepends = webkit2gtk
+ provides = wxlua=3.2.0.2.r13.g4d83c8d
conflicts = wxlua
- source = git://github.com/pkulchenko/wxlua.git
+ source = git+https://github.com/pkulchenko/wxlua.git
sha256sums = SKIP
pkgname = wxlua-git
-
diff --git a/PKGBUILD b/PKGBUILD
index b7c6e92232f3..31d1a1001698 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,59 +6,58 @@
pkgname=wxlua-git
_pkgname=${pkgname/%-git}
-pkgver=3.0.0.8.r22.gdfd9963
+pkgver=3.2.0.2.r13.g4d83c8d
pkgrel=1
epoch=1
-pkgdesc="Lua bindings for wxWidgets (Lua 5.3 compatible fork)"
-arch=('i686' 'x86_64')
+pkgdesc='Lua bindings for wxWidgets (Lua 5.3+ compatible fork)'
+arch=(i686 x86_64)
url="https://github.com/pkulchenko/$_pkgname"
-license=('custom:wxWindows')
-depends=('desktop-file-utils' 'wxgtk2' 'lua')
-makedepends=('git' 'cmake')
-provides=("$_pkgname")
+license=(wxWindows)
+depends=(desktop-file-utils
+ lua
+ wxwidgets-gtk3)
+optdepends=(webkit2gtk)
+makedepends=(cmake
+ git)
+checkdepends=(cppcheck)
+provides=("$_pkgname=$pkgver")
conflicts=("$_pkgname")
-checkdepends=('cppcheck')
-source=("git://github.com/pkulchenko/$_pkgname.git")
+source=("git+$url.git")
sha256sums=('SKIP')
pkgver() {
- cd "${pkgname%-git}"
- git describe --tags --match "v[0-9\.]*" origin/master | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${pkgname%-git}"
+ git describe --tags --match "v[0-9\.]*" HEAD |
+ sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${pkgname%-git}/wxLua/build"
- cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
- -DwxLua_LUA_LIBRARY_USE_BUILTIN=FALSE \
- -DwxLua_LUA_LIBRARY_BUILD_SHARED=TRUE \
- -DwxLua_LUA_LIBRARY="/usr/lib/liblua.so" \
- -DwxLua_LUA_INCLUDE_DIR="/usr/include/" \
- -DCMAKE_BUILD_TYPE=Release \
- -DwxWidgets_COMPONENTS="stc;gl;html;aui;adv;core;net;base" \
- -DwxLuaBind_COMPONENTS="stc;gl;html;aui;adv;core;net;base" \
- -DBUILD_SHARED_LIBS=TRUE
- make
+ cd "${pkgname%-git}/wxLua"
+ cmake -S . -B build \
+ -D CMAKE_BUILD_TYPE=Release \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -D wxLua_LUA_LIBRARY_USE_BUILTIN=False \
+ -D wxLua_LUA_LIBRARY_BUILD_SHARED=True \
+ -D wxLua_LUA_LIBRARY='/usr/lib/liblua.so' \
+ -D wxLua_LUA_INCLUDE_DIR='/usr/include' \
+ -D wxWidgets_COMPONENTS='stc;gl;html;aui;adv;core;net;base' \
+ -D wxLuaBind_COMPONENTS='stc;gl;html;aui;adv;core;net;base' \
+ -D BUILD_SHARED_LIBS=True
+ make -C build
}
package() {
- cd "${pkgname%-git}/wxLua/build"
- make DESTDIR="$pkgdir/" install
- rm -f "$pkgdir"/usr/bin/lua{,c}
+ cd "${pkgname%-git}/wxLua"
+ make -C build DESTDIR="$pkgdir/" install
+ rm -f "$pkgdir"/usr/bin/lua{,c}
- install -d "$pkgdir/usr/lib/lua/5.4"
- mv "$pkgdir/usr/lib/libwx.so" "$pkgdir/usr/lib/lua/5.4/wx.so"
+ install -d "$pkgdir/usr/lib/lua/5.4"
+ mv "$pkgdir/usr/lib/"{lib,lua/5.4/}wx.so
- pushd ..
+ install -Dm644 -t "$pkgdir/usr/share/licenses/$pkgname/" docs/licence.txt
+ install -Dm644 -t "$pkgdir/usr/share/icons/" art/wxlualogo.xpm
- install -Dm644 distrib/autopackage/wxlua.desktop \
- "$pkgdir/usr/share/applications/wxlua.desktop"
-
- install -Dm644 art/wxlualogo.xpm \
- "$pkgdir/usr/share/icons/wxlualogo.xpm"
-
- install -Dm644 distrib/autopackage/wxlua.xml \
- "$pkgdir/usr/share/mime/packages/wxlua.xml"
-
- install -Dm 644 docs/licence.txt \
- "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ pushd distrib/autopackage
+ install -Dm644 "${pkgname%-git}.desktop" -t "$pkgdir/usr/share/applications/"
+ install -Dm644 "${pkgname%-git}.xml" -t "$pkgdir/usr/share/mime/packages/"
}