summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2019-06-05 09:44:32 +0300
committerCaleb Maclennan2019-06-05 09:48:02 +0300
commitc2e0c8c4556fc01271c90596264ce12aca8551f8 (patch)
treea7a958df468418d1b7054d1c0f7d1e6e1b7cc14e
parent8337724c1a435b3ae7a1e434e8ae16b9f4266fc8 (diff)
downloadaur-c2e0c8c4556fc01271c90596264ce12aca8551f8.tar.gz
Port svn package to Lua 5.3 compatible fork
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD51
-rw-r--r--wxlstate.patch14
3 files changed, 24 insertions, 61 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d9fb00292b7c..97859cc1f7db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,24 @@
-pkgbase = wxlua-svn
- pkgdesc = A set of bindings to the wxWidgets library for the Lua programming language - svn version
- pkgver = 252
- pkgrel = 3
- url = http://wxlua.sourceforge.net
+pkgbase = wxlua-git
+ pkgdesc = A set of bindings to the wxWidgets library for the Lua programming language - fork with Lua 5.3 support
+ pkgver = WX_3_1_0.7d9d59.r17.gead9b38
+ pkgrel = 1
+ url = https://github.com/pkulchenko/wxlua
arch = i686
arch = x86_64
arch = armv7h
arch = armv8
license = custom:wxWindows
- makedepends = subversion
+ makedepends = git
makedepends = cmake
depends = desktop-file-utils
depends = wxgtk
- depends = lua52
+ depends = lua
provides = wxlua
provides = wxstedit
conflicts = wxlua
conflicts = wxstedit
- source = wxlua::svn+http://svn.code.sf.net/p/wxlua/svn/trunk
- source = wxlstate.patch
+ source = git://github.com/pkulchenko/wxlua.git
md5sums = SKIP
- md5sums = d4bdd1ccbb3a33abf4e7e33776811038
-pkgname = wxlua-svn
+pkgname = wxlua-git
diff --git a/PKGBUILD b/PKGBUILD
index d7c0ab5b7996..1a5ccb531145 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,52 +4,31 @@
# Contributor: migerh <https://github.com/migerh>
# Contributor: hollunder <murks at tuxfamily dot org>
-pkgname=wxlua-svn
-pkgver=252
-pkgrel=3
-pkgdesc="A set of bindings to the wxWidgets library for the Lua programming language - svn version"
+pkgname=wxlua-git
+pkgver=WX_3_1_0.7d9d59.r17.gead9b38
+pkgrel=1
+pkgdesc="A set of bindings to the wxWidgets library for the Lua programming language - fork with Lua 5.3 support"
arch=('i686' 'x86_64' 'armv7h' 'armv8')
-url="http://wxlua.sourceforge.net"
+url="https://github.com/pkulchenko/wxlua"
license=('custom:wxWindows')
-depends=('desktop-file-utils' 'wxgtk' 'lua52')
-makedepends=('subversion' 'cmake')
+depends=('desktop-file-utils' 'wxgtk' 'lua')
+makedepends=('git' 'cmake')
provides=('wxlua' 'wxstedit')
conflicts=('wxlua' 'wxstedit')
-source=("wxlua::svn+http://svn.code.sf.net/p/${pkgname%-svn}/svn/trunk"
- "wxlstate.patch")
-md5sums=('SKIP'
- 'd4bdd1ccbb3a33abf4e7e33776811038')
+source=("git://github.com/pkulchenko/wxlua.git")
+md5sums=('SKIP')
pkgver() {
- cd ${pkgname%-svn}
- local ver="$(svnversion)"
- printf "%s" "${ver//[[:alpha:]]}"
-}
-
-prepare() {
- cd ${pkgname%-svn}
-
- sed -i -e 's/Exec=wxluaedit/Exec=wxLuaEdit/' wxLua/distrib/autopackage/wxlua.desktop
-
- # wxstedit doc folder fix
- sed -i -e 's|doc/|share/&|' wxLua/modules/wxstedit/CMakeLists.txt
-
- # fix segfault
- cd wxLua
- svn patch "$srcdir/wxlstate.patch"
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd ${pkgname%-svn}/wxLua/
+ cd ${pkgname%-git}/wxLua/
cd build
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_BUILD_TYPE=Release \
- -DwxWidgets_CONFIG_EXECUTABLE=/usr/bin/wx-config \
- -DwxLua_LUA_INCLUDE_DIR=/usr/include/lua5.2 \
- -DwxLua_LUA_LIBRARY=/usr/lib/liblua.so.5.2 \
- -DwxLua_LUA_LIBRARY_USE_BUILTIN=0 \
- -DwxLua_LUA_LIBRARY_VERSION=5.2 \
-DwxWidgets_COMPONENTS="stc;gl;html;aui;adv;core;net;base" \
-DwxLuaBind_COMPONENTS="stc;gl;html;aui;adv;core;net;base" \
-DBUILD_SHARED_LIBS=TRUE
@@ -57,12 +36,12 @@ build() {
}
package() {
- cd ${pkgname%-svn}/wxLua/build
+ cd ${pkgname%-git}/wxLua/build
make DESTDIR="$pkgdir/" install
# mv lua module
- install -d "$pkgdir/usr/lib/lua/5.2"
- mv "$pkgdir/usr/lib/libwx.so" "$pkgdir/usr/lib/lua/5.2/wx.so"
+ install -d "$pkgdir/usr/lib/lua/5.3"
+ mv "$pkgdir/usr/lib/libwx.so" "$pkgdir/usr/lib/lua/5.3/wx.so"
cd ..
diff --git a/wxlstate.patch b/wxlstate.patch
deleted file mode 100644
index 0e631d5d3779..000000000000
--- a/wxlstate.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: modules/wxlua/wxlstate.cpp
-===================================================================
---- modules/wxlua/wxlstate.cpp (revision 251)
-+++ modules/wxlua/wxlstate.cpp (working copy)
-@@ -404,6 +404,9 @@
- if ((m_lua_State == NULL) || m_wxlStateData->m_is_closing || m_lua_State_coroutine)
- return true;
-
-+ if (lua_status(m_lua_State) != LUA_OK)
-+ return true;
-+
- m_wxlStateData->m_is_closing = true;
-
- //wxCHECK_MSG(m_lua_State, false, wxT("Interpreter not created"));