summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-02-11 15:31:40 +0300
committerCaleb Maclennan2020-02-11 15:31:40 +0300
commite44160055c235a5ce46ba0b60dfd4d11ca81a3d4 (patch)
treefb1fd2c7d34b30e729c2bd6dd72a0da8d50ac23f
parent48e5b78ff453b4b6cba34ac4ed85b8a23ac1447a (diff)
downloadaur-e44160055c235a5ce46ba0b60dfd4d11ca81a3d4.tar.gz
Update packaging in line with stable
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD43
2 files changed, 30 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a76ad4e09cb6..3d4e57e21635 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
pkgbase = wxlua-git
- pkgdesc = A set of bindings to the wxWidgets library for the Lua programming language - fork with Lua 5.3 support
- pkgver = WX_3_1_0.7d9d59.r17.gead9b38
- pkgrel = 2
+ pkgdesc = Lua bindings for wxWidgets (Lua 5.3 compatible fork)
+ pkgver = 3.0.0.8.r7.g7684ddf
+ pkgrel = 1
+ epoch = 1
url = https://github.com/pkulchenko/wxlua
arch = i686
arch = x86_64
- arch = armv7h
- arch = armv8
license = custom:wxWindows
+ checkdepends = cppcheck
makedepends = git
makedepends = cmake
depends = desktop-file-utils
- depends = wxgtk
+ depends = wxgtk2
depends = lua
provides = wxlua
- provides = wxstedit
conflicts = wxlua
- conflicts = wxstedit
source = git://github.com/pkulchenko/wxlua.git
- md5sums = SKIP
+ sha256sums = SKIP
pkgname = wxlua-git
diff --git a/PKGBUILD b/PKGBUILD
index 98af5fb0b999..e8036750ed92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,29 +5,34 @@
# Contributor: hollunder <murks at tuxfamily dot org>
pkgname=wxlua-git
-pkgver=WX_3_1_0.7d9d59.r17.gead9b38
-pkgrel=2
-pkgdesc="A set of bindings to the wxWidgets library for the Lua programming language - fork with Lua 5.3 support"
-arch=('i686' 'x86_64' 'armv7h' 'armv8')
-url="https://github.com/pkulchenko/wxlua"
+_pkgname=${pkgname/%-git}
+pkgver=3.0.0.8.r7.g7684ddf
+pkgrel=1
+epoch=1
+pkgdesc="Lua bindings for wxWidgets (Lua 5.3 compatible fork)"
+arch=('i686' 'x86_64')
+url="https://github.com/pkulchenko/$_pkgname"
license=('custom:wxWindows')
-depends=('desktop-file-utils' 'wxgtk' 'lua')
+depends=('desktop-file-utils' 'wxgtk2' 'lua')
makedepends=('git' 'cmake')
-provides=('wxlua' 'wxstedit')
-conflicts=('wxlua' 'wxstedit')
-source=("git://github.com/pkulchenko/wxlua.git")
-md5sums=('SKIP')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+checkdepends=('cppcheck')
+source=("git://github.com/pkulchenko/$_pkgname.git")
+sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "${pkgname%-git}"
+ git describe --tags --match "v[0-9\.]*" origin/master | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "${pkgname%-git}"/wxLua/
-
- cd build
+ cd "${pkgname%-git}/wxLua/build"
cmake .. -DCMAKE_INSTALL_PREFIX=/usr \
+ -DwxLua_LUA_LIBRARY_USE_BUILTIN=FALSE \
+ -DwxLua_LUA_LIBRARY_BUILD_SHARED=TRUE \
+ -DwxLua_LUA_LIBRARY="/usr/lib/liblua.so" \
+ -DwxLua_LUA_INCLUDE_DIR="/usr/include/" \
-DCMAKE_BUILD_TYPE=Release \
-DwxWidgets_COMPONENTS="stc;gl;html;aui;adv;core;net;base" \
-DwxLuaBind_COMPONENTS="stc;gl;html;aui;adv;core;net;base" \
@@ -36,16 +41,14 @@ build() {
}
package() {
- cd "${pkgname%-git}"/wxLua/build
+ cd "${pkgname%-git}/wxLua/build"
make DESTDIR="$pkgdir/" install
- rm "$pkgdir"/usr/bin/lua
- rm "$pkgdir"/usr/bin/luac
+ rm -f "$pkgdir"/usr/bin/lua{,c}
- # mv lua module
install -d "$pkgdir/usr/lib/lua/5.3"
mv "$pkgdir/usr/lib/libwx.so" "$pkgdir/usr/lib/lua/5.3/wx.so"
- cd ..
+ pushd ..
install -Dm644 distrib/autopackage/wxlua.desktop \
"$pkgdir/usr/share/applications/wxlua.desktop"